Bug #41152

Unable to play previous saved games since 1.79

Added by Arsenia Animayhem 2 months ago. Updated 26 days ago.

Status:Closed - Not an IssueStart date:12/16/2019
Classification:Public ItemDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Found In Version:Public Bug Reports - Next Update Category:Client, Steam, User Interface, Win32

Description

After the 1.79 update, I was unable to play saved games from the Pirates of the Swordcoast or Wyvern Crown of Cormyr.

It seems the client does not recognize the previous. I am able to open both of those mods but I need to start with a new character.

It is quote frustrating as I made progress.

module error.jpg (22.1 KB) Arsenia Animayhem, 12/16/2019 08:25 PM

History

#1 Updated by Bill Harper 26 days ago

  • Status changed from New to Closed - Not an Issue

Hi, thanks for the report and we're sorry you've felt frustation from this. The "Closed - Not An Issue" status is misleading--we know this is definitely an issue for you, and I do feel your pain. Unfortunately, it's not a case that we can help with.

While removing the encryption from these modules, we had to rearrange the entire internal structure of the haks. There are new haks that did not exist before, and older ones that were deprecated (and your older saves would ask for them). This was done partly because we discovered & addressed a long-standing bug (dating back beyond 1.69) with haks over 16 characters in name (e.g. "Neverwinter Nights - Wyvern Crown of Cormyr.hak") and asset ordering. We also fixed a lot of issues within the modules, some caused by the decryption but many other long-standing bugs (e.g. the "horse hat" bug in WCoC's character import).

This major overhaul was of such gravity that it affected files which could not be compatible with an older save from the encrypted versions (the hak issue, noted above, mostly). It is indeed unfortunate, but non-preventable in the name of "Greater Progress". With the decryption, eventually we'll be able to release the full set of scripts and the premium modules will be entirely moddable for the very first time. (They can already be opened in toolset where the older ones could not be, but you'll see a lot of "bare bones" currently.)

Again, we're sorry that this affected your save games as well as your game progress. But there is nothing that can be done except to reverse all of our progress and go back to the old encrypted mods eternally. As this was a highly requested feature by the communty at large that we're finally making into a reality, I'm not foreseeing that happening in the near future.

Since you're a Steam player, I suppose you could reverse your game build to "build8186" under the Beta tab and then continue your older saves? You'll lose all of our recent fixes and features doing this, but if keeping your game progress is more important to you then this would be the way to proceed.

Also available in: Atom PDF