Bug #40902

Set/GetCampaign functions, OCSP Stapling

Added by T R 6 months ago. Updated 26 days ago.

Status:Closed - Not an IssueStart date:08/20/2019
Classification:Public ItemDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Found In Version:8189 Category:Persistent World, Server, Win32

Description

Does the build encompass being able to use the Set and GetCampaignInt/String ...etc functions please? I save server time using SetCampaign and then retrieve these values after server restarts. I am aware that Sqlite3 format is now used, but it seems that the module is having issues using the GetCampaign functions. I've read the saved .sqlite3 file and it appears it is indeed saving some of the integers. Am I missing something here please?

Also, I am having troubles getting the server to recognize the OCSP staple. Is there any documentation on this please?

Thank you.

History

#1 Updated by T R 5 months ago

I've figured out how to get the OCSP stapling done, but now getting a libcurl http error for my https address. I am assuming the next following patches will include the newer versions of Get and SetCampaign functions.

#2 Updated by Bill Harper 5 months ago

  • Status changed from New to Needs More Info

Hi, is it possible to see a small version of your mod and this function at work? I've done a lot of testing with a large PW converted entirely over to campaign database, survived the Borland-->SQLLite3 conversions, and had clean readings/writings of many 1000's of entries (of all variable types) for several weeks. So I'd like to see if something is different on your end to show this behavior, and if not try to narrow down the cause. Thanks! We look forward to hearing back from you.

#3 Updated by T R 4 months ago

My apologies on getting back to you now. I could not get on my dev test server (still can't with nwsync) so it was hard to see if the campaign files were working.

I was able to finally get on and confirm that with the newest dev build 8191, the SQlite files are actually working in regards to GetCampaign and SetCampaignInt functions.

You may mark this solved. Thank you.

#4 Updated by Bill Harper 26 days ago

  • Status changed from Needs More Info to Closed - Not an Issue

Hi again, and thanks for getting back with us. I'm glad you managed to get this sorted out, nd it's no longer a problem. I'll get the ticket closed down, good luck in your gaming!

Also available in: Atom PDF