Bug #38858

No XP/kill count for Gamaz's Death

Added by Renaud Thelu 6 months ago. Updated 5 months ago.

Status:Closed - FixedStart date:09/29/2018
Classification:Public ItemDue date:
Assignee:-% Done:

100%

Category:-
Target version:Public Bug Reports - Next Update
Found In Version:Public Bug Reports - 2.5.17.0

Description

Hi guys,

I did not get any XP for killing Gamaz and his death was (logically I guess, since no XP) not added to the kill count of the character who gave the last hit.

Is it normal ?

Is it because it is kind of morally "delicate" to benefit from his death ?

Thank you.

Notes:
Internal report #38860

History

#1 Updated by Renaud Thelu 6 months ago

Some guy on BGEE Steam forum is talking about a 5000 XP reward once Gamaz is dead.

https://steamcommunity.com/app/228280/discussions/0/412447613565605134/

#2 Updated by Richard Hilton 6 months ago

  • Description updated (diff)
  • Status changed from New to Submitted

Thanks

(In version 1.3 of the game XP was given but the final conversation did not take place. Checking to see if XP should be given)

#3 Updated by Renaud Thelu 6 months ago

Ok, because I tried quite a few times and always the same result : no XP, not added to the kill count.

I started this run after the very last update, and I have no mod.
I only have EEKeeper installed ( I use it to reset "HELPMINSC" variable every 6 days until I save Dynaheir) and the CLUA Console activated.

Thank you.

#4 Updated by Richard Hilton 6 months ago

Hi
Versions 2.3 and 2.5 of the game will consistently not give XP or stats

Version 1.3 gave XP. If you need to manually add XP you can use the console command below.
C:Eval('AddexperienceParty(5000)')

#5 Updated by Renaud Thelu 6 months ago

Was it made on purpose or will it be fixed in a later patch ?

#6 Updated by Renaud Thelu 6 months ago

My point is, if it is a bug, then I can add 5000 XP and even add +1 to the counter kill of the character who killed Gamaz via EE Keeper, without actually "cheating". It would just be to make things as they should have been.

However, if it is not a bug, and this is actually a change that developers voluntarily made, then there is no need to use EE Keeper and add anything.

Hence my question. Just want to know what things were intended to be.

Thank you.

#7 Updated by Renaud Thelu 6 months ago

So basically, is it a bug or not ? :)

I would appreciate you tell me, so I can carry on with the game.

Thanks.

#8 Updated by Renaud Thelu 6 months ago

Any answer guys ?

#9 Updated by Renaud Thelu 6 months ago

No answer from devs either on Beamdog forum or here to know whether it is a bug or intended ?

#10 Updated by Julius Borisov 6 months ago

This is a bug, Renaud Thelu, thanks for reporting. The bug is now logged into our internal tracker.

#11 Updated by Richard Hilton 5 months ago

  • Status changed from Submitted to Closed - Fixed

Fixed in version 2.6.0.0

#12 Updated by Anders Svensson 5 months ago

  • Target version set to Next Update
  • % Done changed from 0 to 100

#13 Updated by Renaud Thelu 5 months ago

Great it will be fixed !

When will the version 2.6.0.0 be released ?

#14 Updated by Julius Borisov 5 months ago

Renaud Thelu,

We don't have a release date yet. Please follow our livestreams to get all the latest information first.

Also available in: Atom PDF