Bug #38723

Tiax should detect traps when his AI script is set to do so

Added by Benjamin Peltz about 1 year ago. Updated 12 months ago.

Status:Closed - FixedStart date:09/17/2018
Classification:Public ItemDue date:
Assignee:-% Done:

100%

Category:-
Target version:Public Bug Reports - Next Update
Found In Version:Public Bug Reports - 2.5.17.0

Description

Multi-class characters do not seem to acknowledge the idle mode you can set under the Advance AI settings. For example, my multi-class Fighter-Cleric does not turn undead despite the option being selected under advanced AI, and Tiax does not find traps when idle on my evil team.

Notes:
Internal report #38726

History

#1 Updated by Richard Hilton about 1 year ago

  • Status changed from New to Needs More Info

Hello
Your fighter / cleric will only attempt to turn undead when there are several undead creatures nearby. This has been previously investigated under report #34605 and is working as intended.

Creating a multi-class gnome cleric / thief sees advanced AI detect traps. Tiax does not have this as an action within his script so we could convert this report to cover that scenario. Does that sound OK.

Thanks

#2 Updated by Benjamin Peltz about 1 year ago

Richard Hilton wrote:

Hello
Your fighter / cleric will only attempt to turn undead when there are several undead creatures nearby. This has been previously investigated under report #34605 and is working as intended.

Creating a multi-class gnome cleric / thief sees advanced AI detect traps. Tiax does not have this as an action within his script so we could convert this report to cover that scenario. Does that sound OK.

Thanks

Good to know, thanks for following up!

#3 Updated by Richard Hilton about 1 year ago

  • Subject changed from Multi-Class AI Not Working Properly to Tiax should detect traps when his AI script is set to do so
  • Description updated (diff)
  • Status changed from Needs More Info to Submitted

Thanks

#4 Updated by Richard Hilton 12 months ago

  • Status changed from Submitted to Closed - Fixed

Fixed in version 2.6.0.0
(although Tiax encountered or recruited in an earlier version of the game may still have the issue)

#5 Updated by Anders Svensson 12 months ago

  • Target version set to Next Update
  • % Done changed from 0 to 100

Also available in: Atom PDF