Bug #38580

During black Pits Tier 1 Battle three game crashes

Added by Tony DiCamillo over 1 year ago. Updated 10 months ago.

Status:Closed - FixedStart date:08/31/2018
Classification:Public ItemDue date:
Assignee:-% Done:

100%

Category:-
Target version:Public Bug Reports - Next Update
Found In Version:Public Bug Reports - 2.5.17.0

Description

I literally just started a fresh run of black pits a few hours ago running version 2.5.17 from the start of it, and ran into the same problem. I imported one character (Slandish) the rest of them were all new characters.

As soon as I kill the necromancer the game freezes, nothing is allowed to move and keybindings do not work. I still hear the cheering.

The first time it happened it just switched to the beam dog intro moviefreeze framed at the first frame
On the next two tries it only switched to the beamdog intro movie(freeze framed) after I used CTRL+ALT+DEL to get out of the game.

Notes:
Internal report #38584

000000020-.zip - My save file. (156 KB) Tony DiCamillo, 08/31/2018 09:42 PM

History

#1 Updated by Thomas van Golen over 1 year ago

I tried your save on an unmodded BG:EE game. I started the fight, Ctrl + Y'd the necromancer and everything continued as it should be (skeletons dying, Baeloth appearing and transporting the party back).

#2 Updated by Richard Hilton over 1 year ago

  • Description updated (diff)
  • Status changed from New to Submitted

Hello
As above, however waiting for Llyrk to start a summoninng spell and killing him before it completes sees the game freeze so reported on that basis.

Thanks

#3 Updated by Richard Hilton over 1 year ago

  • Status changed from Submitted to Closed - Fixed

Fixed in version 2.6.0.0

#4 Updated by Anders Svensson over 1 year ago

  • Target version set to Next Update
  • % Done changed from 0 to 100

#5 Updated by Alfred Morgan 10 months ago

Duplicate of #38727 and this problem has not been fixed. I posted there the steps to reproduce and also the workaround.

Also available in: Atom PDF