Bug #38462

Stuck after defeating Korlasz (showstopper)

Added by John Bleichert 7 months ago. Updated 7 months ago.

Status:Closed - Not an IssueStart date:08/20/2018
Classification:Public ItemDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Found In Version:Public Bug Reports - 2.5.17.0

Description

So I cleared out the Korlasz family tomb, finished The Shattered Staff quest, defeated Korlasz (let her leave and enter the custody of the Flaming Fist) and now I'm stuck.

If I go up the stairs north of the Library, as soon as I get to the top the HUD disappears and the game stops accepting mouse and keyboard input. It's not frozen, it looks like it wants to start a cut scene, but it does not do so. I need to kill the game via the Task Manager.

If I go up the rope to meet Imoen, as soon as I get to the top of the rope the HUD disappears and the game stops accepting mouse and keyboard input. Again it's not frozen, it looks like it wants to start a cut scene, but it does not do so. Need to kill the game via the Task Manager.

Interestingly, the x, y coords are -1 at the rope (see bg1-bug, attached).

Windows 10, Pro and Home, 64-bit, installed and played via steam, on "hard" difficulty. Some time this week I will play it again from the end of BG1.

Suggestions? I'd like to play SoD and then head into BGII with this PC.

Thanks,

John

bg1-bug.png - x,y coords at the rope (885 KB) John Bleichert, 08/20/2018 06:03 PM

sodsave_000000028-SoD Current.cloud.meta (10 Bytes) John Bleichert, 08/21/2018 09:57 PM

sodsave_000000028-SoD Current.cloud (962 KB) John Bleichert, 08/21/2018 09:57 PM

000000000-Auto-Save.rar (822 KB) Anton Valeriev, 08/25/2018 11:05 AM

000000200-BD0120 start 1.zip (827 KB) Richard Hilton, 08/25/2018 01:07 PM

History

#1 Updated by Kristin Warren 7 months ago

  • Status changed from New to Needs More Info

Thank you for the bug report!

Couple of questions for you to try and figure out what's going on here:
- Did you load an autosave or a quick save at any point before you used the rope?
- Did you complete the whole dungeon in one session (ie: did you close the game then resume from a save)?
- Was this save started on an earlier version of the game?
- Did you participate in the BG:EE 2.5 beta?

Cheers!

#2 Updated by John Bleichert 7 months ago

Hi Kristin,

- Did you load an autosave or a quick save at any point before you used the rope?

Several times. I wandered back and forth between the stairs and the rope looking for anything I missed. Reloaded steam, even rebooted.

- Did you complete the whole dungeon in one session (ie: did you close the game then resume from a save)?

Not sure I understand this question. I finished BG1:EE, followed the automatic path into SoD, met Imoen and the Flaming Fist people, saved the game, and then a couple rainy days later reloaded the game at that point and cleaned out the Korlasz tomb.

- Was this save started on an earlier version of the game?

I don't think so? I had purchased and installed SoD (and BGII:EE) several weeks prior to finishing BG1:EE.

- Did you participate in the BG:EE 2.5 beta?

No, I don't believe so. I believe I have beta testing turned "off" for BG1:EE. I do not have access to steam here at work but will check once I get home later tonight.

Let me know if you need me to upload some game files. No problem. I can even load the game on my Macbook Pro if you think it will help.

Thanks,

John

#3 Updated by Kristin Warren 7 months ago

It's sounding like it may be something with continuing an old save in 2.5. Would you be able to upload a save from before when the issue occurs? Also, and I know this is a bit of a pain, but could you try re-importing your save from BG and running through the dungeon again to see if it happens when playing through the whole thing on 2.5?

Cheers, and thank you for your patience!

#4 Updated by John Bleichert 7 months ago

I will upload a game save file when I get home. Will be later on tonight, EST.

No problem with the re-import and re-run, I intended to do that anyway!

Thanks,

John

#5 Updated by John Bleichert 7 months ago

My current save game is attached here. From this save game, going to either the stairs or the rope yields the results described above.

I will not get to the reload/replay until later in the week but will update then. Let me know if you need anything else.

John

#6 Updated by Daniel Rehr 7 months ago

How to reproduce:
1. Start a new game in SoD v2.3
2. Save the game as soon as you gain control over the party
3. Load the game in SoD v2.5

Notes
The same effect can be triggered in a pure SoD v2.5 game by entering the following console command:

C:SetGlobal("BD0120_START","GLOBAL",0)

#7 Updated by John Bleichert 7 months ago

Is the post above strictly informational? Or can I use a similar console command to allow me to continue forward in SoD?

#8 Updated by Daniel Rehr 7 months ago

John Bleichert wrote:

Is the post above strictly informational? Or can I use a similar console command to allow me to continue forward in SoD?

You can use this command if you're still on the lower level:

C:SetGlobal("BD0120_START","GLOBAL",1)

You'll probably have to use EE Keeper to set the variable if you're already in the top level area, since the faulty cutscene triggers too quickly.

#9 Updated by John Bleichert 7 months ago

Daniel Rehr wrote:

You can use this command if you're still on the lower level:
[...]

Daniel - thanks for that - I will try it out when I get home (I am, indeed, stuck on the lower level).

#10 Updated by John Bleichert 7 months ago

Daniel, Kristin - thanks for the help! The console command worked like a charm. Got to the Ducal Palace, all is well.

Don't see any way to close this? Do we leave it open?

#11 Updated by Richard Hilton 7 months ago

  • Status changed from Needs More Info to Closed - Not an Issue

Thanks for advising, will close this report.

#12 Updated by Anton Valeriev 7 months ago

I have the same issue. I'm on second floor of tomb, trying to get back to the first(where you start) floor. I can't enable console.

#13 Updated by Richard Hilton 7 months ago

Try this Anton

#14 Updated by Anton Valeriev 7 months ago

It worked, thanks.

Also available in: Atom PDF