Bug #37004

Journal entry "Tazok and the bandits" should clean up correctly in situations both before and after the letters from Tazok's tent has been picked up.

Added by Søren Madsen over 1 year ago. Updated 11 months ago.

Status:Closed - FixedStart date:05/06/2018
Classification:Public ItemDue date:
Assignee:-% Done:

100%

Category:-
Target version:Public Bug Reports - Next Update
Found In Version:Public Bug Reports - 2.5.15.1

Description

1. Load attached save.
Note: Memorize the location of the party, you will need to return to the tent in front of them in step 6.
2. Enter Tazok's tent (the big one on the right side of the screen with a porch)
3. "Raemon" initiates dialog, answer by using either option 1 or 2 to initiate combat.
4. Kill the four enemies.
5. Open the big chest besides "Endar Sai" and take the two letters inside to start chapter 4.
6. Return to the tent where the party stood when you loaded the save and enter the tent.
7. "Knott" initiates dialog, answer by using options: 1,2,2,2 to receive the quest "Tazok and the bandits" = This quest now can't be cleared from the quest log due to the fact that you already have picked up the two letters from the chest in Tazok's tent.

Note: If the quest is completet normally it does'nt resolve as intended with a (Finished) marker, but simply vanishes from the quest log. This can be tested by doing the process of the steps above in reverse, simply by speak with "Knott" first and then loot the letters from Tazok's tent afterwards. When you pick the letters from the chest, the quest vanishes from the quest log.

Observed: The quest "Tazok and the bandits" can't be completet after the letters from Tazok's tent has been picked up, neither does it resolve with a (Finished) marker if done correctly.

Expected: It should be possible for the quest log entry "Tazok and the bandits" to resolve correctly with a (Finished) marker, in situations both before and after the letters from the chest in Tazok's tent has been picked up.

Notes: Internal report #38022.

Bug Report.zip (348 KB) Søren Madsen, 05/06/2018 05:49 PM

History

#1 Updated by Søren Madsen over 1 year ago

  • File Bug Report.zip added
  • Subject changed from Journal entry to Journal entry "Tazok and the bandits" should clean up correctly in situations both before and after the letters from Tazok's tent has been picked up.

1. Load attached save.
Note: Memorize the location of the party, you will need to return to the tent in front of them in step 6.
2. Enter Tazok's tent (the big one on the right side of the screen with a porch)
3. "Raemon" initiates dialog, answer by using either option 1 or 2 to initiate combat.
4. Kill the four enemies.
5. Open the big chest besides "Endar Sai" and take the two letters inside to start chapter 4.
6. Return to the tent where the party stood when you loaded the save and enter the tent.
7. "Knott" initiates dialog, answer by using options: 1,2,2,2 to receive the quest "Tazok and the bandits" = This quest now can't be cleared from the quest log due to the fact that you already have picked up the two letters from the chest in Tazok's tent.

Note: If the quest is completet normally it does'nt resolve as intended with a (Finished) marker, but simply vanishes from the quest log. This can be tested by doing the process of the steps above in reverse, simply by speak with "Knott" first and then loot the letters from Tazok's tent afterwards. When you pick the letters from the chest, the quest vanishes from the quest log.

Observed: The quest "Tazok and the bandits" can't be completet after the letters from Tazok's tent has been picked up, neither does it resolve with a (Finished) marker if done correctly.

Expected: It should be possible for the quest log entry "Tazok and the bandits" to resolve correctly with a (Finished) marker, in situations both before and after the letters from the chest in Tazok's tent has been picked up.

#2 Updated by Søren Madsen over 1 year ago

  • File deleted (Bug Report.zip)

#3 Updated by Anders Svensson over 1 year ago

  • Description updated (diff)

#4 Updated by Anders Svensson over 1 year ago

  • Description updated (diff)
  • Status changed from New to Submitted

#5 Updated by Anders Svensson 11 months ago

  • Status changed from Submitted to Closed - Fixed
  • Target version set to Next Update
  • % Done changed from 0 to 100

Fixed in version 2.6.0.0.

Also available in: Atom PDF