Bug #36103

Dorn should not get stuck attempting to initiate dialogue with player character after killing Kryll.

Added by Utkarsh Raizada over 1 year ago. Updated 11 months ago.

Status:Closed - FixedStart date:03/22/2018
Classification:Public ItemDue date:
Assignee:-% Done:

100%

Category:-
Target version:Public Bug Reports - Next Update
Found In Version:Public Bug Reports - 2.3.67.3

Description

1. Load the attached save.
2. Move party south to initiate encounter with Kryll.
3. Kill Kryll.
4. Dorn and Player Character attempt to initiate dialogue but get interrupted. (This should not happen and the dialogue should trigger successfully).

The above issue occurs if I keep Dorn out of combat entirely or solo the fight with Dorn.

Notes

Internal report: #36106

000000041-sa.zip (284 KB) Utkarsh Raizada, 03/22/2018 06:27 AM

History

#1 Updated by Richard Hilton over 1 year ago

  • Project changed from Infinity Engine Public Bugs to BG:EE Public Bugs
  • Status changed from New to Submitted

Thanks.

As a workaround, take him to a temple and get Remove Curse cast on him.

#2 Updated by Utkarsh Raizada over 1 year ago

Richard Hilton wrote:

Thanks.

As a workaround, take him to a temple and get Remove Curse cast on him.

Thanks, I loaded an earlier save and removed the curse. Encounter worked as intended then.

#3 Updated by Anders Svensson over 1 year ago

  • Description updated (diff)

#4 Updated by Richard Hilton 11 months ago

  • Status changed from Submitted to Closed - Fixed

Fixed in version 2.6.0.0

#5 Updated by Anders Svensson 11 months ago

  • Target version set to Next Update
  • % Done changed from 0 to 100

Also available in: Atom PDF