Bug #35886

Bug with scripts in Black Pits

Added by Andrey Sizonenko over 1 year ago. Updated about 1 year ago.

Status:Closed - FixedStart date:03/08/2018
Classification:Public ItemDue date:
Assignee:-% Done:

100%

Category:-
Target version:Public Bug Reports - 2.5.17.0
Found In Version:Public Bug Reports - 2.5.10

Description

Sorry, I'm using Google.Translate.

After the victory in the arena of the Red Wizards of Thay, Baeloth teleports me from the arena and asks Najim to give out the award. But, Najim does not appear, accordingly, I receive no reward. Goods from merchants are updated. After I tell Baeloth that I'm ready for the next battle, there is no script run on the transfer to the arena. The game freezes and it has to be forced off.

P.S. perhaps this bug only in the Russian localization.

Notes:
Internal report #35891

20180308213504_1.jpg - Script transfer to arena not working (150 KB) Andrey Sizonenko, 03/08/2018 10:06 AM

20180308213445_1.jpg - Najim does not appear (249 KB) Andrey Sizonenko, 03/08/2018 10:06 AM

000000027-1.rar - Savegame (80 KB) Andrey Sizonenko, 03/08/2018 11:17 AM

000000028-Added Najim.zip (70.7 KB) Richard Hilton, 03/08/2018 12:10 PM

000000001-Quick-Save.rar - Savegame 2 (86.4 KB) Andrey Sizonenko, 03/08/2018 01:58 PM

20180309014947_1.jpg - Najim in arena (284 KB) Andrey Sizonenko, 03/08/2018 01:59 PM

History

#1 Updated by Richard Hilton over 1 year ago

  • Status changed from New to Needs More Info

Hello
Do you have a save before that combat that you could attach.

Could you also advise what platform this is for (Windows, Mac, Linux, iOS, Android).
Thanks

#2 Updated by Andrey Sizonenko over 1 year ago

  • File 000000001-Quick-Save-2.rar added

Steam for Windows

#3 Updated by Richard Hilton over 1 year ago

Hi
That looks like a BG campaign save, not a Black Pits one?

#4 Updated by Andrey Sizonenko over 1 year ago

  • File deleted (000000001-Quick-Save-2.rar)

#5 Updated by Andrey Sizonenko over 1 year ago

Sorry, this wrong savegame. Where to find savegame from Black Pits?

#6 Updated by Andrey Sizonenko over 1 year ago

Found

#7 Updated by Richard Hilton over 1 year ago

Thanks.

Najim is deactivated. I have activated him in the attached save and the game appears to continue if you want to try it. Will need to investigate whether he should be present - can you remember anything unusual happening before as it's likely that whatever the issue is, it's already happened and we need to go back further to identify the cause.

#8 Updated by Richard Hilton over 1 year ago

  • Description updated (diff)
  • Status changed from Needs More Info to Submitted

#9 Updated by Andrey Sizonenko over 1 year ago

After killing clay golems, Baeloth causes a Najim to enter the arena and the game freezes.

#10 Updated by Anders Svensson over 1 year ago

  • Description updated (diff)

#11 Updated by Richard Hilton over 1 year ago

OK. I ran your save through the retail v2.3 game and it was fine so good catch.

You can either revert back to 2.3 or leave your save until the issue can be investigated further and an appropriate fix identified.

Thanks

#12 Updated by Richard Hilton over 1 year ago

  • Status changed from Submitted to Closed - Fixed

Fixed in build v2.5.13.2

#13 Updated by Anders Svensson over 1 year ago

  • Target version set to Next Update
  • % Done changed from 0 to 100

#14 Updated by Anders Svensson about 1 year ago

  • Target version changed from Next Update to 2.5.17.0

Also available in: Atom PDF