Feature #34985

[Android] mod archives created with centralfix don't work properly (partial content only)

Added by Denis Ribayrol almost 2 years ago. Updated about 1 year ago.

Status:Closed - FixedStart date:01/16/2018
Classification:Public ItemDue date:
Assignee:-% Done:

100%

Category:-
Target version:Public Bug Reports - 2.5.17.0
Found In Version:Public Bug Reports - 2.5.10

Description

Several types of files do not seem to be recognized by the game when added as mod archive edited with centralfix:
- dialog.tlk and dialogF.tlk in languages other than english, i.e. in directory other than lang/en_US (the files are accepted if copied in lang/en_US): french tested by myself, czech and korean reported by others
- bif files containing voice over in french (taken from the Windows version) are not recognized when in lang/fr_FR/data

This used to work properly with version 1.3.

First test : mods installed in french on the game set in french language + addition of voice over in french (copied from Windows version)

Mod set used:
  • BG1 NPC
  • BG1 NPC music
  • BG1 Unfinished Business
  • Finch
  • Thalantyr Item Upgrade
Files transfered to Android in files directory:
  • dialog.tlk and dialoF.tlk in lang/fr_FR in a centralfixed archive (Mods-BG1NPC-UB-Finch-Thalan_txt.zip)
  • override directory content from installing these mods zipped then unzipped on Android
  • additionnal centralfixed file (SoundsFrBeamdog.zip) containing content of lang/fr_FR/data (bif files for french voices) and lang/fr_FR/sounds (french sound sets for main character) from PC version of BGEE V2.5, and a few more sound files in lang/fr_FR/movies, notably ERROR01.WAV ("You must gather your party...") in french
Texts triggered in game:
  • Finch in Candlekeep, Imoen talks from BG1 NPC about Tarnesh book and arriving in Beregost
  • All displayed as "Invalid xxxxx" in french language. Original game texts (tutors in Candlekeep) are displayed properly, in french.
Sounds used by the game:
  • all game voices are in english, except
  • main character voice in french (from lang/fr_FR/sounds) and "You must gather..." in french (from lang/fr_FR/movies)
Summary of first test:
  • dialog.tlk and dialogF.tlk in lang/fr_FR are not taken into account
  • bif files in lang/fr_FR/data are not taken into account
  • sound files in lang/fr_FR/sounds are used
  • sound files in lang/fr_FR/movies are used (acting as override folder)

Second test: text files and sounds moved to lang/en_US, english language selected in game

Files transfered to Android in files directory:
  • dialog.tlk and dialoF.tlk in lang/en_US, data and movies moved from lang/fr_FR to lang/en_US (lang/fr_FR/sounds not moved so as to not override english sound for the main character), all included in a centralized archive (SoundsFrBeamdog_in_enUS.zip)
  • override directory content zipped then unzipped on Android
Texts triggered in game:
  • same as for test 1
  • all displayed properly, in french language (language chosen to install the mods). Original game texts (tutors in Candlekeep) are also displayed properly, in french (i.e. the dialog.tlk override works when in lang/en_US).
Sounds used by the game :
  • all game voices are in english, except
  • sound "You must gather..." in french
Summary of second test:
  • dialog.tlk (at least, not sure for dialogF.tlk) in lang/en_US taken into account (dialog.tlk made from french game file and from mods properly overriding original english dialog.tlk)
  • bif files in lang/en_US/data are not taken into account (maybe en_US is hard coded to look for them in the data directory together with other bif files)
  • sound file in lang/en_US/movies is used (acting as override folder)
Steps to reproduce test 1:
  • copy file SoundsFrBeamdog.zip (attached) to Android/data/com.beamdog.baldursgateenhancededition/files
  • copy file override.zip (attached) to Android/data/com.beamdog.baldursgateenhancededition/files, then extract its content
  • copy file SonsFrBeamdog.zip (see below how to build it) to Android/data/com.beamdog.baldursgateenhancededition/files
  • change game language to french
  • start a new game
  • head close to the monks singing the Alaundo quotes: notice the voices are in english
  • head to Finch nearby and start conversation: notice the texts are all "Invalid xxxxx"
  • load a save game with a team of several persons in a big building
  • move one character far away from the door to leave the building
  • select the whole group and click on the door to leave: notice that the voice to gather the party is in french
File SonsFrBeamdog.zip is too big to be attached. It contains:
  • lang/fr_FR/data from the Windows version
  • lang/fr_FR/sounds from the Windows version
  • lang/fr_FR/movies/ERROR01.WAV attached to this report
  • all packed in an uncompressed zip archive and processed by centralfix
    I'll upload it and will provide a link, if needed.

For additional details and additional feedback from other playeds : https://forums.beamdog.com/discussion/43990/how-to-install-mods-on-android/p4

Internal Report #35976

Mods-BG1NPC-UB-Finch-Thalan_txt.zip - dialog.tlk and dialogF.tlk in french with mod texts (19.5 MB) Denis Ribayrol, 01/16/2018 06:22 PM

override.zip - mods files in override directory (23.8 MB) Denis Ribayrol, 01/16/2018 06:23 PM

ERROR01.WAV - "You must gather..." voice in french (16.7 KB) Denis Ribayrol, 01/16/2018 06:36 PM

History

#1 Updated by Kristin Warren over 1 year ago

  • Tracker changed from Bug to Feature

Flipping to feature request for the triage group to look at.

#2 Updated by Denis Ribayrol over 1 year ago

I disagree on tagging it as a feature request: this is a regression compared to V1.3.
Especially since the voice over is not available in French (and some other languages) on Android, contrary to V2.x on computers (unless this changes when 2.5 is released as non beta, which hasn't been mentioned). Using centralfix is currently the only way to add VO in their language for Android players.

#3 Updated by Kristin Warren over 1 year ago

  • Description updated (diff)
  • Status changed from New to Submitted

#4 Updated by Anders Svensson over 1 year ago

  • Status changed from Submitted to Closed - Fixed
  • Target version set to Next Update
  • % Done changed from 0 to 100

Hopefully fixed in version 2.5.16.4.

#5 Updated by Anders Svensson about 1 year ago

  • Target version changed from Next Update to 2.5.17.0

Also available in: Atom PDF