Bug #34337

[Android] Odd Small Girl - Yxunomei BUG

Added by Szymon Siudak almost 2 years ago. Updated 12 months ago.

Status:Closed - FixedStart date:12/14/2017
Classification:Public ItemDue date:
Assignee:-% Done:

100%

Category:-
Target version:Public Bug Reports - 2.5.16.3
Found In Version:Public Bug Reports - 2.5.10

Description

I have serious problem with last fight in Chapter 2. Unfortunately the Odd Small Girl doesn't change to Yxunomei after conversation (the script doesn't work). I tried many times, I even started the level 5 again. I used save games from previous lvl (Dragon's Eye lvl 4) but nothing is working. I stuck and I can't continue game.

I attached video to show you the problem and save game file to check what is wrong.

My device:
Samsung Galaxy TAB S2 (Exynos 7 Octa)
Android 7

Notes:
Internal report #34342

Icewind Dale_2017-12-14-08-19-35.mp4 (15.2 MB) Szymon Siudak, 12/14/2017 02:36 AM

Screenshot_20171214-084821.png - Device description 2 (174 KB) Szymon Siudak, 12/14/2017 02:49 AM

Screenshot_20171214-084840.png - Device description 1 (221 KB) Szymon Siudak, 12/14/2017 02:49 AM

Screenshot_20171214-084811.png - Device description 3 (264 KB) Szymon Siudak, 12/14/2017 02:49 AM

000000029-Odd Small Girl BUG.zip - Save game files (258 KB) Szymon Siudak, 12/14/2017 03:05 AM

000000012-Yxunomei.zip (226 KB) Richard Hilton, 12/14/2017 05:57 AM

000000046-Dual.zip (198 KB) Ricardo Gancz, 01/11/2018 05:58 PM

000000029-Bota.zip (224 KB) Ricardo Gancz, 01/11/2018 05:58 PM

000000047-Dual pc.zip (156 KB) Richard Hilton, 01/11/2018 06:13 PM

000000048-Bota PC.zip (157 KB) Richard Hilton, 01/11/2018 06:13 PM

000000037-yxunomei_hidden.zip (237 KB) Ladislav Smola, 01/13/2018 04:13 AM

000000038-Yxunomei back.zip (229 KB) Richard Hilton, 01/13/2018 04:33 AM

000000001-Quick-Save.zip (179 KB) Paul Teale, 01/15/2018 02:16 PM

000000033-Yxunomei prep.zip (144 KB) Richard Hilton, 01/15/2018 02:34 PM

BALDUR.SAV (127 KB) Michael Rowland, 01/21/2018 11:56 PM

BALDUR.gam (84.4 KB) Michael Rowland, 01/22/2018 11:26 PM

000000000-Auto-Save.zip (220 KB) Richard Hilton, 01/25/2018 07:02 AM

000000024-dr4.zip (271 KB) Miroslav Klimes, 01/27/2018 07:24 AM

000000025-dr5.zip (257 KB) Miroslav Klimes, 01/27/2018 07:24 AM

000000039-dr5 Yxunomei.zip (213 KB) Richard Hilton, 01/27/2018 08:29 AM

000000033-Broken Save.zip (175 KB) Jacob Muhlestein, 01/27/2018 07:31 PM

000000491-Yxunomei.zip (207 KB) Richard Hilton, 01/28/2018 03:55 AM

000000001-Quick-Save-4.zip (275 KB) Prosper Mocuvkar, 01/30/2018 02:09 PM

000000492-Yxunomei again.zip (211 KB) Richard Hilton, 01/30/2018 02:17 PM

000000001-Yxunomei.zip (218 KB) Joshua Witting, 02/05/2018 03:16 PM

000000021-Yxunomei 5 Feb.zip (202 KB) Richard Hilton, 02/05/2018 03:26 PM

000000024-oddgirlbug-josh.zip (277 KB) Joshua Jansen, 02/27/2018 04:20 AM

000000025-Odd Girl Bug - Josh resaved.zip (223 KB) Richard Hilton, 02/27/2018 11:46 AM

000000045-Bug.zip - complete disaster (174 KB) Nicholas Fyr, 03/05/2018 09:13 PM

000000490-Yxunomei.zip (151 KB) Richard Hilton, 03/06/2018 01:43 PM

000000001-Quick-Save-4.zip (292 KB) Echis ., 03/07/2018 01:25 AM

000000491-Echis Yxunomei.zip (219 KB) Richard Hilton, 03/07/2018 12:43 PM

000000027-try.rar (265 KB) Fred Cederstrom , 03/08/2018 01:16 PM

000000492-Try Yxunomei.zip (215 KB) Richard Hilton, 03/08/2018 03:12 PM

BALDUR.bmp (64.1 KB) Filip Brzezinski, 12/02/2018 12:06 PM

BALDUR.gam (232 KB) Filip Brzezinski, 12/02/2018 12:06 PM

BALDUR.SAV (119 KB) Filip Brzezinski, 12/02/2018 12:06 PM

PORTRT0.bmp (13.5 KB) Filip Brzezinski, 12/02/2018 12:06 PM

PORTRT1.bmp (13.5 KB) Filip Brzezinski, 12/02/2018 12:06 PM

PORTRT2.bmp (13.5 KB) Filip Brzezinski, 12/02/2018 12:06 PM

PORTRT3.bmp (13.5 KB) Filip Brzezinski, 12/02/2018 12:06 PM

PORTRT4.bmp (13.5 KB) Filip Brzezinski, 12/02/2018 12:06 PM

000000001-Quick-Save.rar (206 KB) Filip Brzezinski, 12/02/2018 12:08 PM

000000535-Yxunomei transform.zip (203 KB) Richard Hilton, 12/02/2018 01:41 PM

History

#1 Updated by Szymon Siudak almost 2 years ago

I forgot to inform I'm using new 2.5 beta patch.

#2 Updated by Richard Hilton almost 2 years ago

Hi
Your save works fine on the PC version - I've attached a forced save just after she transforms so you can continue, and will look to reproduce the issue on Android.

Thanks

#3 Updated by Richard Hilton almost 2 years ago

  • Description updated (diff)
  • Status changed from New to Submitted

#4 Updated by Szymon Siudak almost 2 years ago

I've just started Chapter 3. Thank you!
I'll let you know if I find more issues.

#5 Updated by Ricardo Gancz almost 2 years ago

I am using the new 2.5 beta patch. I am happy as finally the game is working but had this same problem as Szymon had.
I am sending one save of my original game after the dialog, after killing everyone around and resting but without Yxunomei transformed and also another save (with a modded char I used to redo all the chapter) before the dialogue. I appreciate if any of them is corrected.

Thank you,

#6 Updated by Richard Hilton almost 2 years ago

Hi, try these files
(& please don't change the status of reports)

Thanks

#7 Updated by Richard Hilton almost 2 years ago

  • Status changed from New to Submitted

#8 Updated by Ladislav Smola almost 2 years ago

Hello. I am on Icewind Dale beta. Android 8. Yxuonomei is hidden and I can't progress. Here is the save. Could you apply some magic, please? :-)

#9 Updated by Richard Hilton almost 2 years ago

Sure, give this a try.

#10 Updated by Ladislav Smola almost 2 years ago

Richard Hilton wrote:

Sure, give this a try.

Awesome, that was quick. :-) Works like a charm. Thak you very much.

#11 Updated by Paul Teale almost 2 years ago

I have the same issue, she stays on the odd little girl and is invincible

Please fix my attached save file

#12 Updated by Richard Hilton almost 2 years ago

Hi
Try this.

Thanks

#13 Updated by Michael Rowland almost 2 years ago

I have run into this same issue.

#14 Updated by Anders Svensson almost 2 years ago

The BALDUR.gam file is needed as well.

#15 Updated by Michael Rowland almost 2 years ago

Here you go.

#16 Updated by Richard Hilton almost 2 years ago

Hi, save attached after the dialogue

#17 Updated by Miroslav Klimes almost 2 years ago

Hi, please help me, the same problem, little girl Yxunomei is invicible and untouchable. Can you fix my save? Thanks a lot. (Android 7.0, Nvidia Shield K1, IWDEE Beta 2.5)

#18 Updated by Richard Hilton almost 2 years ago

Here you go

#19 Updated by Miroslav Klimes almost 2 years ago

It works, your magic is really powerfull and speed is incredible :-) Thank you.

#20 Updated by Jacob Muhlestein almost 2 years ago

Same as everyone else. Would you fix my file? (Samsung Galaxy Tab S2)

#21 Updated by Richard Hilton almost 2 years ago

Here you go

#22 Updated by Jacob Muhlestein almost 2 years ago

Thanks man, You saved the day! Back to dungeon crawling

#23 Updated by Prosper Mocuvkar almost 2 years ago

Hello, same problem here. Could you help me please?

#25 Updated by Joshua Witting almost 2 years ago

Could you please help me as well? Thanks!

#26 Updated by Richard Hilton almost 2 years ago

Sure.

Sorry you are all encountering this issue but thank you all for continuing your testing.

#27 Updated by Anders Svensson almost 2 years ago

  • Status changed from Submitted to Closed - Fixed
  • Target version set to Next Update
  • % Done changed from 0 to 100

Fixed in version 2.5.11.0.

#28 Updated by Richard Hilton over 1 year ago

For reference the workaround is to
  • Get the Android save
  • Load it on desktop (Windows, Mac or Linux)
  • If the little girl has already spoken, make a save
  • If she has not spoken, speak to her and once she transforms make a save
  • Return that save for Android

If unable to make a save due to hostiles, force a console autosave via C:Eval('SaveGame(0)')

#29 Updated by Joshua Jansen over 1 year ago

Hi, I was hoping somebody would be able to help me out as well. I'm in the same boat, and help would be greatly appreciated. Sorry

#31 Updated by Joshua Jansen over 1 year ago

Richard Hilton wrote:

Here you go

A million thanks, man!

#32 Updated by Nicholas Fyr over 1 year ago

Hello, I have the same problem. Could you help? This bug ruined my heart. She's just not morphing into what she meant to.

Im on PC version.

#33 Updated by Richard Hilton over 1 year ago

Hmm, should work OK on PC for you. Save attached but can you confirm what version of the game you are using and whether any mods are installed.

Thanks.

#34 Updated by Nicholas Fyr over 1 year ago

Thank you very much! It works! I hope you win the lottery.

#35 Updated by Echis . over 1 year ago

Hello, same problem here. Could you help me please? Thank you.

#36 Updated by Richard Hilton over 1 year ago

Yep, try this

#37 Updated by Echis . over 1 year ago

Thanks!!!!

#38 Updated by Fred Cederstrom over 1 year ago

I too am suffering from this problem.

#39 Updated by Richard Hilton over 1 year ago

Here you go

#40 Updated by Anders Svensson over 1 year ago

  • Target version changed from Next Update to 2.5.16.3

#41 Updated by Filip Brzezinski 12 months ago

I have the same problem, can you please fix it? My save is attached

#42 Updated by Filip Brzezinski 12 months ago

Filip Brzezinski wrote:

This one is compressed.

#43 Updated by Richard Hilton 12 months ago

Hello
While it looks similar this is not the same issue. Please try the attached save.

Thanks

#44 Updated by Filip Brzezinski 12 months ago

Filip Brzezinski wrote:

Sorry, but the issue is still in place. Yxunomei stands in the middle room, invincible and there is nothing I can do about it - i can't even return to Kuldahar, because of the door. I can attack her how much I want, but nothing will happen. Thanks for looking into the issue, but it appears I would use little more help.

#45 Updated by Richard Hilton 12 months ago

You did try the save I attached? It works when I try.

n.b. you do need to use +2 weapons, normal or +1 are ineffective.

Also available in: Atom PDF