Bug #34212

Mac Crash to Desktop

Added by Phil Irey almost 2 years ago. Updated about 1 year ago.

Status:Closed - FixedStart date:12/09/2017
Classification:Public ItemDue date:
Assignee:-% Done:

100%

Category:-
Target version:Public Bug Reports - 2.5.17.0
Found In Version:Public Bug Reports - 2.5.10

Description

1) Load attached save game.
2) Send Abdel to talk to Coran on the bridge.
3) Select 1 (Yes, tell us more)
4) Select 1 (Yea)
5) End Dialogue
6) Select rightmost character (Coran? - would be nice to give name when hovering over characters in a list)
7) Select "Remove" to remove rightmost character
8) Select "Remove" in response to "Are you sure?" prompt.
9) The app crashes to desktop

Notes:
Internal report #34413

There is no crash file in the "Documents\Inifinity Engine - Enhanced Edition" folder.

Thanks,

phil

000000113-Set Up for Koran Crash.zip - Setup save game for crash after trying to remove Coran from party (570 KB) Phil Irey, 12/09/2017 03:08 PM

Baldurs Gate Crash when removing Coran from Party.rtf - Crash dump from OS (56.9 KB) Phil Irey, 12/09/2017 05:38 PM

Baldr012.jpg (6.31 KB) Richard Hilton, 12/10/2017 04:53 AM

Baldr099.jpg (50.2 KB) Richard Hilton, 12/10/2017 04:53 AM

History

#1 Updated by Phil Irey almost 2 years ago

The problem occurs in Baldurs Gate EE 2.5.10.1 only (on a Mac running 10.13.2). I can do the same steps on the retail version of the game and Coran is successfully removed from the party and says farewell.

#2 Updated by Phil Irey almost 2 years ago

Sorry, I meant to post this to the infinity engine project rather than here.

#3 Updated by Richard Hilton almost 2 years ago

  • Project changed from IWD:EE Public Bugs to BG:EE Public Bugs

#4 Updated by Richard Hilton almost 2 years ago

  • Status changed from New to Needs More Info

Hello
Please can you try verifying your game. I have been able to use your save and steps to recruit and remove Kivan both on Mac (albeit 10.12.6) and PC.

Thanks

#5 Updated by Phil Irey almost 2 years ago

I verified the game but still see the issue in the 2.5.10.0 beta. This time I got a crash log from the OS. I cut the text from it and pasted it into the attached file.

I don't see this issue with the retail version of the game using the same steps.

#6 Updated by Richard Hilton almost 2 years ago

OK, could you try the below to see if it can be narrowed down at all.
  • If you boot another party member instead of Coran does it crash
  • If you boot another party member before asking Coran to join does it crash when he joins
  • If he joins at the previous step, can you retry and repeat your steps with another party member booted first
  • Does moving all sound sliders to the minimum settings make any difference
  • Does switching to fullscreen to windowed mode (or vice versa) make any difference
  • Does starting a new game and using the two console commands below work (then Ctrl/J to his location and get him to join
    C:MoveToArea("AR2200")
    C:ExploreArea()
Plus a bit more information
  • Which store did you purchase from, Steam or Beamdog. If Steam, are cloud saves enabled and does disabling them help
  • Do you have Siege of Dragonspear DLC (retail) installed in the beta build
  • Is Coran the first character you've booted with a full party
  • Do you have any mods at all installed
  • Was the save started on an earlier version of the game (Neera's portrait looks a bit like this may be the case). If so, was it modded.

#7 Updated by Phil Irey almost 2 years ago

  • Found In Version set to 2.5.10

I tried booting each original party member individually from the list with Coran and did not see the issue. The party member left and Coran was added to the party. On thing to note is that when I tried to load the original save game to try the next party member, the game crashed to desktop. Unfortunately, the OS didn't produce a crash log and again no crash log showed up in the "Infinity Engine - Enhanced Edition" directory for any of these crashes.

I tried booting a party member prior to talking to Coran. After I agreed to join his quest, he was added to the party as expected. I also tried to reform the party after Coran was added by removing him and then adding back the original member I booted prior to talking to him. This worked as well. I was able to reform the party several times by swapping Coran for another party member several times with no issues.

I set all sound settings to minimum and it still crashed when I tried to boot Coran.

The testing I did previously (and above) was in full screen mode. When I tested in windowed mode, it crashed the same as before.

I added the "SetPrivateProfileString('Program Options','Debug Mode','1') " line to the baldur.lua file and am able to bring up the console with control-space (after turning of spotlight use of this key sequence). I'm not sure now to enter the C: commands, however. Where do I type these? I don't see a text entry area in the console box that comes up.

I was able to travel to AR2200 by selecting AR2200 in the scrolling list and then hitting the "Travel" button. I then went to Coran with an entirely new party that I created from scratch via a new game. When I added Coran and then kicked him out it crashed to desktop again.

I originally purchased the game from the Mac App store. I got frustrated when I upgraded to the late 2016 MacBook Pro 15" and the text in the game was too small to see and kept getting cut of so I couldn't see all of it. I waited for a very long time for the 2.x upgrade which I understood fixed this problem. About a month ago I decided to buy the game again from the Beamdog store and copied my save games. It seemed to work so I thought everything was fine until you asked me the question about where I bought it from. Would this explain why Neera's portrait is different?

Is there another way to import Mac App store save games into a Beamdog store version?

I don't have Siege of Dragonspear installed in the beta or in non-beta.

Coran is the first character I've booted from the full party.

I have no mods installed.

I copied my Mac App Store 1.3 save games into a Beamdog Store production version directory as explained above.

Another problem I'm running into with the 2.5.10 version (which made some of the above hard to do) is that the cursor keeps changing to what looks like a scrolling cursor. It is a right angle point up with a period underneath it on top of a square which is on top of a period with a right angle pointing down underneath it. What makes the cursor change and how can I change it back? The only way I have found to change back is to exit the game?

Thanks,

phil

#8 Updated by Richard Hilton almost 2 years ago

Opening the console should allow you to type into the box below the dialogue window. If there is no red line cursor, click in the box and you should then be able to type.

If your cursor is shown like this, the current action is to change the party order by dragging one portrait above or below another. This should only happen if you click and hold the mouse button while over a party member. Releasing the button should return the cursor to normal.

What mouse / trackpad are you using - do you have an alternate device you could try to see if it is doing something unusual. There is another recent report where a mac user is experiencing control issues https://support.baldursgate.com/issues/34153

#9 Updated by Richard Hilton almost 2 years ago

Copying saves from one machine to another should be fine. Copying from v1.3 to later versions should generally be OK although there is potential for us to break backward compatibility. I don't think that is the case here though.

#10 Updated by Phil Irey almost 2 years ago

I am using a late 2016 MacBook Pro (13,1) and am using the trackpad on it only. There is a big issue using it with 2.5.10. The trackpad works fine with the retail version. I see the same problems as in Report #34153. When I

When I try to select the debug mode text entry box, it is very difficult to get it to allow me to enter text, The cursor keeps changing from the finger pointer to the party order cursor even though I'm only hovering the mouse over the area near the debug text entry box. Even with the finger pointer, I can rarely get it into a mode that allows me to enter text. When I do and start typing, it allows me to enter only a character or two before I can't type any more. I tried this in the retail version and do not have this issue. I can enter the commands into the debug mode text area with ease. The problems start on the opening screen where moving your finger on the trackpad to try to select "Baldurs Gate" results in click sounds from the game even though I'm just moving the cursor. Random buttons appear to be depressed as you move around.

The one time I was able to enter the 'C:MoveToArea("AR2200")' command, it said 'string "c:MoveToArea("AR2200")"]:1: attempted to index global 'c' (a nil value)'. It also gives the same result in the retail version. Am I entering the text correctly?

#11 Updated by Richard Hilton almost 2 years ago

The string is case sensitive so c:MoveToArea("AR2200") will fail but C:MoveToArea("AR2200") would work

Are you able to temporarily disable Force touch to see if the game works as expected, we can then be more confident about the cause and report on a factual basis. (sample link: http://cupertinotimes.com/disable-force-touch-trackpad-on-macbook-pro/)

Thanks

#12 Updated by Phil Irey almost 2 years ago

I turned off the Force Touch. It didn't help with the trackpad control issues. Something appears to be interpreting touches on the trackpad as clicks rather than just movement. The buttons being pressed when the click sounds happen are not in the same location as where the cursor is.

After I entered the two console commands, Ctrl/J'd to Coran's location, and asked him to join the party, the game crashed when I removed him from the party.

#13 Updated by Richard Hilton almost 2 years ago

OK, thanks for trying that Phil.

#14 Updated by Richard Hilton almost 2 years ago

Screen capture attached on other report about a particular position on the touchpad which seems to be selecting other buttons. Don't know if it is similar for you.

#15 Updated by Phil Irey almost 2 years ago

Yes, I see the same exact problem on the menu screens. When the cursor is not over one of the menu buttons, trackpad touches (but not touching hard enough for a click) on certain parts of the trackpad it is interpreted as a trackpad click in a menu button on different part of the screen. I think this also might be triggering the scrolling cursor change I keep running into.

#16 Updated by Richard Hilton almost 2 years ago

It may be the tap to click setting. Would need to check but it appears as if the tap is intepreted as if the screen was touched at the same location so top left of trackpad selects top left of screen and so on.

Sample link http://osxdaily.com/2014/01/28/enable-tap-to-click-mac-trackpad/

#17 Updated by Phil Irey almost 2 years ago

I see what the issue is now.

I verified that tap to click is happening inside the beta version of the game but it is not happening in the retail version of the game or outside of the game.

I didn't realize that every time I tap the trackpad with a finger in the game it is being interpreted as a click. This is very confusing if you aren't expecting it.

I re-checked settings and it had "Tap to click" turned off. I then toggled "Tap to click" by turning it on and then back off. This didn't change the behavior.

I also tested with an external Logitech USB mouse. This works fine with no issues.

#18 Updated by Richard Hilton almost 2 years ago

Now we have the trackpad issue reported separately, we ought to get back to the crash. If you use your mouse does the crash still happen. & are you seeing the blue BG:EE user interface, or do you have the black SoD user interface.

Thanks

edit: & having rechecked (OSX updated to 10.13.2) I can now repro the crash.

#19 Updated by Richard Hilton almost 2 years ago

  • Description updated (diff)
  • Status changed from Needs More Info to Submitted

#20 Updated by Phil Irey almost 2 years ago

I tried removing Coran using the mouse rather than the trackpad and I still see the crash. While most of the time I don't see an OS crash dump, it produced one with a backtrace which was essentially the same as the previous on I attached.

I have the blue BG:EE UI. (I don't own SoD yet).

#21 Updated by Richard Hilton over 1 year ago

  • Status changed from Submitted to Closed - Fixed

Fixed in build v2.5.13.2 (under #33635)

#22 Updated by Anders Svensson over 1 year ago

  • Target version set to Next Update
  • % Done changed from 0 to 100

#23 Updated by Anders Svensson about 1 year ago

  • Target version changed from Next Update to 2.5.17.0

Also available in: Atom PDF