Bug #34153

[Mac] Interface doesn't correctly register clicks

Added by Astro BryGuy about 1 year ago. Updated 5 months ago.

Status:Closed - FixedStart date:12/08/2017
Classification:Public ItemDue date:
Assignee:-% Done:

100%

Category:-
Target version:Public Bug Reports - 2.5.17.0
Found In Version:Public Bug Reports - 2.5.10

Description

When using the v2.5.10 BGEE beta, I found that the interface does not always correctly register clicks.

1. I often hear the BG "clicking" sound when touching my trackpad to move the cursor.
2. When I do attempt to click on the trackpad, the cursor does the "clicking" animation, but the click will not register or will depress a button not underneath the current cursor location.
3. Getting BGEE to register the click correctly sometimes requires a "hard click" (I am using a trackpad with Force Touch). Even then it does not always register.

I have attached two videos of interacting with the Gameplay Options screen, one of BGEEv2.3 and one of BGEE v2.5.

Everything works under v2.3. I can adjust the sliders, select options, and click the buttons.

Under v2.5, clicking on the sliders with a normal click does not adjust the slider. It often results in the Assign Keys button depressing. Only if I use a "hard click" does the slider work. For the radio buttons, pressing them with a normal click resulted in a separate UI element animating (e.g., the Feedback button). I was able to select the Gore option once with a "hard click", but I could not replicate. Even "hard clicks" usually resulted in another UI element animating.

Notes:
Internal report #34256

I am on a 2017 MacBook Pro with High Sierra.

BGEEv2.3.mov - BGEE v2.3.67 Gameplay Options screen (3.81 MB) Astro BryGuy, 12/08/2017 01:40 PM

BGEEv2.5.10.mov - BGEE v2.5.10 Gameplay Options screen (10.3 MB) Astro BryGuy, 12/08/2017 01:40 PM

IWDEEv2.5.10_ForceTouchOff.mov (5.86 MB) Astro BryGuy, 12/10/2017 01:43 PM

Mac touchpad center right.mp4 (2.29 MB) Richard Hilton, 12/10/2017 04:16 PM

Mac touchpad six places.mp4 (2.73 MB) Richard Hilton, 12/10/2017 04:31 PM

TrackpadLocations.mov (7.52 MB) Astro BryGuy, 12/10/2017 09:35 PM

IMG_4197.MOV (27.6 MB) Astro BryGuy, 05/01/2018 11:10 PM

History

#1 Updated by Richard Hilton about 1 year ago

  • Subject changed from Interface doesn't correct register clicks to [Mac] Interface doesn't correct register clicks

#2 Updated by Astro BryGuy about 1 year ago

  • Subject changed from [Mac] Interface doesn't correct register clicks to [Mac] Interface doesn't correctly register clicks

Note: I see these issues when using the trackpad. I do not see them when using an external mouse.

#3 Updated by Richard Hilton about 1 year ago

Thanks. To help determine what is happening, if you temporarily disable force touch does the trackpad work correctly in that mode.

#4 Updated by Astro BryGuy about 1 year ago

I turned off Force Touch, but the issues still continued to happen. It looks like it's affecting all the v2.5.10 games.

I've attached a video capture of IWDEE. At first, I am able to select the "Max HP" and "Group Infravision" options. However, after that clicks stop registering correctly (continued clicks don't turn Infravision off). Then, continued clicks start depressing the "Feedback" and "Assign Keys" buttons (although those screens don't activate). Also, I still hear the "click sounds" when moving the cursor.

#5 Updated by Richard Hilton about 1 year ago

Hello
I can get a similar result if I tap one particular area on a trackpad (the centre of the right half of it). This is an older Macbook Pro, don't know if it is the same for you.

edit, and if I tap slightly above or below the buttons above or below then activate. If I tap on the centre left of the trackpad, the leftside buttons activate.

#7 Updated by Richard Hilton about 1 year ago

  • Status changed from New to Submitted

Submitting report but would appreciate confirmation you also see particular areas of the trackpad interacting with the game buttons.

#8 Updated by Richard Hilton about 1 year ago

  • Description updated (diff)

#9 Updated by Astro BryGuy about 1 year ago

You figured it out! That's it exactly. I hadn't noticed that it depended on where on the trackpad I was clicking.

I confirmed with IWD:EE on my MacBook Pro (see video). I was able to locate the "zones" for the three buttons in the Gameplay Options and the Cancel/Done buttons.

My hat is off to your sleuthing skills!

#10 Updated by Astro BryGuy 9 months ago

Note: Still affecting the v2.5.15.1 BGEE beta, as well as the v2.5.16.3 IWDEE release.

See: https://support.baldursgate.com/issues/36932

#11 Updated by Anders Svensson 7 months ago

  • Status changed from Submitted to Closed - Fixed
  • Target version set to Next Update
  • % Done changed from 0 to 100

Fixed in version 2.5.16.4 (internal build).

#12 Updated by Anders Svensson 5 months ago

  • Target version changed from Next Update to 2.5.17.0

Also available in: Atom PDF