Bug #32913

"Journal updated" messages doesn't create journal entries

Added by Gareth Jones about 2 years ago. Updated about 1 year ago.

Status:Closed - FixedStart date:10/06/2017
Classification:Public ItemDue date:
Assignee:-% Done:

100%

Category:-
Target version:Public Bug Reports - 2.5.17.0
Found In Version:Public Bug Reports - 2.3.67.3

Description

When playing the game I get "journal updated" messages, that have a title and a block of text.

These seem to indicate a new journal entry, and when I press the message block the journal is opened up, showing that entry.

However it seems that some (actually most that are not direct quest updates) "journal updated" messages don't actually create journal entries, such as shown in my attached screenshot.

If these messages should be generating journal entries, then this is a bug.

If this is by design, then this is a feature request: whenever I'm given a "journal updated" message that contains a paragraph of story, a journal entry with the same text should be created for later reading.

This has been annoying when playing on a 4K monitor, as I like to read larger entries in the journal rather than in the popup window, as the pop-up window's text is very small and nearly unreadable at 4k without scaling turned on.

Notes

Neera's romance reported internally as #34649.

baldurs-gate-ee-bug.png (1.71 MB) Gareth Jones, 10/06/2017 11:30 PM

History

#1 Updated by Anders Svensson almost 2 years ago

  • Description updated (diff)
  • Status changed from New to Submitted

#2 Updated by Anders Svensson almost 2 years ago

  • Description updated (diff)

#3 Updated by Anders Svensson over 1 year ago

  • Status changed from Submitted to Closed - Fixed
  • Target version set to Next Update
  • % Done changed from 0 to 100

Fixed in version 2.5.12.11.

#4 Updated by Anders Svensson about 1 year ago

  • Target version changed from Next Update to 2.5.17.0

Also available in: Atom PDF