Bug #32537

[Windows] Beetles should spawn

Added by Thomas Carr about 2 years ago. Updated about 1 year ago.

Status:Closed - FixedStart date:09/16/2017
Classification:Public ItemDue date:
Assignee:-% Done:

100%

Category:-
Target version:Public Bug Reports - 2.5.17.0
Found In Version:Public Bug Reports - 2.3.67.3

Description

1. Load save SpidersDead.
2. Exit the cave without crossing the trigger (around x230 y720).
3. Exit the Forest of Wyrms and choose to travel to the Troll Claw Woods.
4. Return to the Forest of Wyrms (you might end up in a unique encounter rather than the Troll Claw Woods, I don't think it matters).
5. Enter the cave.
6. Walk over the trigger.

Observed:
Nothing happens.

Expected:
An event should trigger wherein a Rhino Beetle and several smaller beetles spawn in the cave.

Notes:
Internal report #32540

SpidersDead is a save I created while attempting to reproduce the bug. Tom25 and Tom26 are saves from my main playthrough. Tom25 is before entering the cave, Tom26 is after exiting the cave (without the beetles spawning) and leaving the Forest of Wyrms. If you load Tom26 and return to the cave, crossing the trigger does not lead to the beetles spawning.
I think I originally missed the trigger as only my main character crossed it and he was wearing boots of speed. I have checked, and it is possible for him to cross the trigger without spawning the beetles, although this does not seem to happen consistently. I then continued exploring and left the Forest of Wyrms. This appears to have killed the trigger permanently.

000000057-SpidersDead.zip (1.08 MB) Thomas Carr, 09/16/2017 12:52 PM

000000049-Tom25.zip (1.1 MB) Thomas Carr, 09/16/2017 12:52 PM

000000051-Tom26.zip (1.09 MB) Thomas Carr, 09/16/2017 12:53 PM

000000463-Tom26 Edit.zip (1.06 MB) Richard Hilton, 09/16/2017 07:32 PM

000000038-Tom13.zip (1.12 MB) Thomas Carr, 10/02/2017 12:55 PM

000000039-Tom13 edit.zip (1.13 MB) Richard Hilton, 10/02/2017 01:51 PM

000000145-Spider Eggs.zip (1.01 MB) Tobias Braun, 03/01/2018 04:04 AM

000000198-Beetle.zip (1.02 MB) Richard Hilton, 03/01/2018 04:37 AM

History

#1 Updated by Richard Hilton about 2 years ago

  • Description updated (diff)
  • Status changed from New to Submitted

#2 Updated by Richard Hilton about 2 years ago

Thanks.

You've probably moved on but I've attached a save which should work if you wanted to use it.

#3 Updated by Thomas Carr about 2 years ago

Thank you. Sorry for the late reply. My main save was about five hours further on. I've attached the file. It's a little presumptuous, but would it be possible to edit that file?

#4 Updated by Richard Hilton about 2 years ago

Hi
Try this save

#5 Updated by Thomas Carr about 2 years ago

That worked. Thanks a lot!

#6 Updated by Anders Svensson almost 2 years ago

  • Status changed from Submitted to Closed - Fixed
  • Target version set to Next Update
  • % Done changed from 0 to 100

Fixed in version 2.5.3.0.

#7 Updated by Tobias Braun over 1 year ago

Is someone so nice as to fix my save-game as well? I'm going through bd0114.BCS but can't figure out how to fix it yet?

#8 Updated by Richard Hilton over 1 year ago

Try this
(I copied actor 4 from the base area bd0114 into the save bd0114, loaded the game and killed it)

#9 Updated by Tobias Braun over 1 year ago

Your manual save-game fix worked for me - thank you very much!

#10 Updated by Anders Svensson about 1 year ago

  • Target version changed from Next Update to 2.5.17.0

Also available in: Atom PDF