Bug #32481

Commoner near Rasaad should not have nothing to say to you when talked to.

Added by Faalagorn . about 2 years ago. Updated about 1 year ago.

Status:Closed - FixedStart date:09/09/2017
Classification:Public ItemDue date:
Assignee:-% Done:

100%

Category:-
Target version:Public Bug Reports - 2.5.17.0
Found In Version:Public Bug Reports - 2.3.67.3

Description

1. Load the attached save.
2. Try to talk to Commoner in Orange, standing in front of Rasaad.

Observed:
"Commoner: has nothing to say to you." message appears.

Expected:
Commoner should have some dialogue when talked to, just like other NPCs.

Notes:
Internal report #33795

It's the commoner that mocks Rasaad that disappears later. He also have no audio cues when right clicked, similar to other 3 commoners standing near Rasaad, although they correctly initiate dialogue.

rasaadbugs.zip (257 KB) Faalagorn ., 09/09/2017 01:00 PM

Screenshot from 2017-09-09 19-02-07.png (1.81 MB) Faalagorn ., 09/09/2017 01:02 PM

History

#1 Updated by Richard Hilton about 2 years ago

  • Subject changed from [Linux] Commoner near Rasaad should not have nothing to say to you when talked to. to [Journal] Commoner near Rasaad should not have nothing to say to you when talked to.

#2 Updated by Faalagorn . about 2 years ago

Thank you for updating description of my bug reports, but keep in mind that this particular bug and Bug #32482 are not essentially related to journal, but to the creature files missing interaction in it's dialogue file and sounds respectively :). The creatures in question are RSCOMN01, RSCOMN02, RSCOMN03 and RSCOMN04.

I also realized that the names of the platform is (correctly!) removed (or replaced) by the time the bug is submitted and the issue is affecting all platforms (as expected), though even if I'm pretty much sure the issue should be independent of platform, I still follow the guidelines on how to report bugs (recently uploaded here on Wiki, thanks Julius Borisov!) that suggest including the platform – should I still follow it or is it easier if I would submit new bugs without the platform in brackets when I'm pretty much certain the issue is not specific to the platform?

#3 Updated by Richard Hilton about 2 years ago

  • Subject changed from [Journal] Commoner near Rasaad should not have nothing to say to you when talked to. to Commoner near Rasaad should not have nothing to say to you when talked to.

Hi
You can put the platform detected on in the notes section. If it is specific to Linux, i.e. you are certain it cannot be reproduced elsewhere it's OK to leave the subject tag. I will check with Julius though as I may have missed a reporting change.

I'll remove the journal tags for the two you mention.
Thanks

#4 Updated by Richard Hilton almost 2 years ago

  • Description updated (diff)
  • Status changed from New to Submitted

#5 Updated by Anders Svensson almost 2 years ago

  • Status changed from Submitted to Closed - Fixed
  • Target version set to Next Update
  • % Done changed from 0 to 100

Fixed in version 2.5.11.0.

#6 Updated by Anders Svensson about 1 year ago

  • Target version changed from Next Update to 2.5.17.0

Also available in: Atom PDF