Bug #32093

Imported character with non-humanoid appearance/paper doll should not crash the game. [Mod Limitation Issue/Request]

Added by Brad L about 2 years ago. Updated about 1 year ago.

Status:Closed - FixedStart date:08/19/2017
Classification:Public ItemDue date:
Assignee:-% Done:

100%

Category:-
Target version:Public Bug Reports - 2.5.17.0
Found In Version:Public Bug Reports - 2.3.67.3

Description

Description:
  1. Add CRTrnk to the Character File import directory.
    Documents\Baldur's Gate - Enhanced Edition\characters
  2. Start a new game.
  3. Click Import.
  4. Import 'Trinket - Monk'
  5. Press the Appearance button.

Observed:
Game Crashes.

Desired:
The game should not crash and either display the correct paperdoll or just show the empty window where the paperdoll is.

Notes:
  • The only way to change the paperdoll is to mod it with EE-Keeper or similar so thats why I set it as a feature request.
  • Have included the crash dump file, hoping at the very least I can find out the cause.
  • It dosnt do it with all paperdolls. It works with Imp (which has no paperdoll), and Mindflayer (which has a paper doll) and others.
  • CRTrnk crashes the game (Bear). Tried with appearance BEARBR an bearbrsu (Brown Bear), BEARBL (Black Bear) and bearca (Cave bear)
  • CRDimt works. Is an imp
  • CRGald works. Is a wolf.
  • CRClta works. Is a Mindflayer

Internal Report #31090

Chr File Bug.zip (780 KB) Brad L, 08/19/2017 01:57 AM

History

#1 Updated by Richard Hilton about 2 years ago

Hello
It might be to do with the colours chosen (this based on https://support.baldursgate.com/issues/28053).

#2 Updated by Brad L about 2 years ago

I think you are on the right track.

To test I loaded the save game with a un-moded Druid I levelled up. Shape changed into a Bear and pressed the Change Colour Button in the inventory menu. It crashed the game. This means that it effects all shapechangers or Druids who change into a bear, as well as Wilson. Which is good for me since Im guessing there is a higher chance it will be fixed if its broken in the base un-modded game lol. Im not sure if it effects any other forms or polymorph tho.

-To also test, which im not sure is helpful, I manually changed all the present colours to [Colour Gradient 10, 0x09, Light Pure Gold] and tried it. That colour is a colour I know works but it also crashed the game still.
-I also tried adding effects that override the colour of an NPC similar to the Barkskin or other enchantments. I set him to all blue and tested. It crashed to.

So since that seems to be a base game bug that effects un-modded BG games. Should I change this feature to bug and say it effect Druid Shape change? Or should I add a Bug reference to mine for Bug #28053 ? Or will you update it your end :)

Thanks for the feedback!

#3 Updated by Richard Hilton about 2 years ago

That report is based on changing in-game, I've added a note to the internal ticket about polymorphed characters so thanks for suggesting it.

For your edited characters, does changing one of them to the colours of an existing creature work. i.e. do a brown or black bear work and a purple bear not. It may be the case that some creatures have a limited range of colours available or no colour beyond a default setting.

#4 Updated by Brad L about 2 years ago

Im going to ask the EE-Keeper creator if im correct and update if im wrong. But this is how I believe it works.

As far as I can tell, any non-main race paperdolls (Human, Elf, etc) Dont look at or at least are not visually affected by Pallet colours. With a few exceptions such as Dyrads which I can only imagine are a coded variant of the main races so it lets you change the clothing and skin. For Bears and other other shapechanged creatures the game dosnt actually change your colour pallet as it dosnt need to because it just swaps out the sprite that is displayed. This is the reason why if you were to cast say Barkskin on a bear or other creature it looks the same as Pallet colours dont work on it.

That being the case I can guess the issue could be that the Bears are trying to look at or apply colours (perhaps a side effect from the Wilson implementation now being a character?) and because its impossible it crashes.

I did change and test a colour anyway as I said above but that didnt fix it. I also tried the default pallet colours of a brand new Druid and that didnt work either. Their are 119 Colours so if their is one that works its going to be a hard time finding it from my end as I have no idea what colour might be the fix if any. But even if I did set it to any colour and it wont change it anyway so im not sure if that will help. In fact from what I can tell your colours dont even change at all when you shapechange. When I check my appearance colours in the editor after a shapechange they are the same as they were not shape changed.

That being said the only other way to colour a non main race sprite is to tint its entire body though RGB. But even the RGB dosnt change how the sprite looks in the inventory or appearance menu. It only changes it in the game world and is used for magic effects such as glowing blue from a protection spell. And this RPG colour change is not applied (as far as I can tell) when you are shapechanged to a bear or anything else. I did try changing the bear to Blue anyways to see if it did anything to no avail.

As I said im no expect im just guessing most of this but I hope that helps some what.

#6 Updated by Kristin Warren about 2 years ago

  • Description updated (diff)
  • Status changed from New to Submitted

Thanks for the suggestion! We're moving this to our internal tracking system for further consideration. Please note, this isn’t a guarantee we’ll implement the feature or that it will appear as you’ve suggested as we may find another solution, or discover it is more complicated than originally thought.

#7 Updated by Anders Svensson almost 2 years ago

  • Tracker changed from Feature to Bug
  • Status changed from Submitted to Closed - Fixed
  • Target version set to Next Update
  • % Done changed from 0 to 100

Fixed in version 2.5.3.0.

#8 Updated by Anders Svensson about 1 year ago

  • Target version changed from Next Update to 2.5.17.0

Also available in: Atom PDF