Bug #31937

'Hold' status effect from Aec'Letec attack should not be called 'Paralyze' in combat log

Added by Orlon Kronsteen about 2 years ago. Updated about 1 year ago.

Status:Closed - FixedStart date:08/13/2017
Classification:Public ItemDue date:
Assignee:-% Done:

100%

Category:-
Target version:Public Bug Reports - 2.5.17.0
Found In Version:Public Bug Reports - 2.3.67.3

Description

1. Start battle with Aec'Letec.
2. Observe the status effects from his attacks in the game log

Observed: The 'Hold' status effect from Aec'Letec's attack is incorrectly listed as 'Paralyze' in game log.

Expected: The 'Hold' status effect from Aec'Letec's attack should be listed as 'Hold' in game log.

Notes:
Internal report #31937

Aec_Letec.PNG (37.9 KB) Orlon Kronsteen, 12/01/2017 09:31 AM

History

#1 Updated by Richard Hilton almost 2 years ago

  • Status changed from New to Needs More Info

Hello
Would you be able to provide further information in this respect.

The intent looks clear when you look at the scripting.
IF
See([PC])
Global("Paralyze","GLOBAL",0)
THEN
RESPONSE #100
ForceSpell([PC],TANARI_PARALYZE) // SPIN999.SPL (Paralyze)
SetGlobal("Paralyze","GLOBAL",1)
END

Thanks

#2 Updated by Orlon Kronsteen almost 2 years ago

Hi there, I gather from what CamDawg was saying that what you're seeing in the scripting is inaccurate, though I really don't know anything about under-the-hood mechanics. Here is a link to the thread in which CamDawg describes the problem. The thread itself might provide the context to the problem, and Cam's quote states exactly what the problem is. I've also attached a snippit of Cam's quote, should that be helpful. Other than that, I can't provide any insight as I don't know anything about coding or modding the game (I was randomly asked to report the problem and was happy to do so). You might talk to CamDawg, I guess, if you're working with him.

https://forums.beamdog.com/discussion/65640/aecletec

#3 Updated by Richard Hilton almost 2 years ago

  • Description updated (diff)
  • Status changed from Needs More Info to Submitted

Thanks, will get it in the pot.

#4 Updated by Richard Hilton over 1 year ago

  • Status changed from Submitted to Closed - Fixed

Fixed in build v2.5.15.0

#5 Updated by Anders Svensson over 1 year ago

  • Target version set to Next Update
  • % Done changed from 0 to 100

#6 Updated by Anders Svensson about 1 year ago

  • Target version changed from Next Update to 2.5.17.0

Also available in: Atom PDF