Bug #31664

Branwen's name is "Statue".

Added by Christian Venter about 2 years ago. Updated about 1 year ago.

Status:Closed - FixedStart date:07/23/2017
Classification:Public ItemDue date:
Assignee:-% Done:

100%

Category:-
Target version:Public Bug Reports - 2.5.17.0
Found In Version:Public Bug Reports - 2.3.67.3

Description

Me and my friend have been playing BG:EE in multiplayer and when we unpetrified Branwen her name didn't change.

Her name is now stuck on "Statue" and her race shows as none. We have tried kicking her, but it had no effect.

This issue is really distracting and we can't seem to find any solution to this problem on the internet.

We are running the latest version with no mods.

Notes

Internal report: #31427

mpsave.rar (2.44 MB) Christian Venter, 07/29/2017 07:10 PM

000000001-Quick-Save-2.bg1save (448 KB) Brett Dixon, 05/11/2018 12:03 PM

Branwen.bg1save (340 KB) Richard Hilton, 05/11/2018 01:52 PM

History

#1 Updated by Anders Svensson about 2 years ago

  • Description updated (diff)
  • Status changed from New to Submitted

#2 Updated by Anders Svensson about 2 years ago

Try the following in the console:
C:Eval('ActionOverride("Branwen",SetName(9499))')
C:Eval('ChangeRace("Branwen",HUMAN)')

Do you have a save game you could attach?

#3 Updated by Christian Venter about 2 years ago

Entering those console commands seems to have fixed our issues!

I still attached our mpsave folder if you want to try and analyze what caused it.

Thank you for your effort.

#4 Updated by Anders Svensson about 2 years ago

Thanks! We think we know what is happening so hopefully we can fix the root cause of this.

#5 Updated by Anders Svensson almost 2 years ago

  • Status changed from Submitted to Closed - Fixed
  • Target version set to Next Update
  • % Done changed from 0 to 100

Fixed in version 2.5.11.0.

#6 Updated by Brett Dixon over 1 year ago

This recently occurred to me on a game on IOS version 2.4.71.4. I had an additional complication:

I uncursed Branwen and interacted her, but did not add her to the party immediately as I wanted to drop characters off in another location to make room. When I returned, she was again a statue, and I had to repeat the process to turn her back.

She then has kept the Statue name. She should be in the part in this save: If not, she is in the Friendly Arms.

#7 Updated by Richard Hilton over 1 year ago

This will still be an issue until iOS updates to version 2.5. Console commands above have been applied to the attached save so please try that.

Thanks

#8 Updated by Anders Svensson about 1 year ago

  • Target version changed from Next Update to 2.5.17.0

Also available in: Atom PDF