Bug #24865

MoveViewPoint function broken with Allow Scrolling out side of Bounds

Added by john huxley over 3 years ago. Updated almost 2 years ago.

Status:Closed - Not an IssueStart date:07/09/2016
Classification:Public ItemDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Found In Version:Public Bug Reports - 2.3.67.3

Description

Hi,

Some cutscenes for my mod have suddenly stopped working properly
where i use MoveViewPoint with speed VERY_FAST to move the screen across the map, my camera is on the edge of the map.

It works if i tick 'Allow scrolling outside of Bounds' in the game graphics options.

It stops working if i untick 'Allow scrolling outside of Bounds' in the game graphics options.

History

#1 Updated by john huxley over 3 years ago

Just to clarify, the camera panning via MoveViewPoint is not working if 'Allow scrolling outside of bounds' is unticked.

#2 Updated by john huxley over 3 years ago

  • Subject changed from MoveToPointNoInterrupt function broken with Allow Scrolling out side of Bounds to MoveViewPoint function broken with Allow Scrolling out side of Bounds

#3 Updated by john huxley over 3 years ago

  • Description updated (diff)

#4 Updated by john huxley over 3 years ago

I suspect this happens when your camera is actually on the edges of the map.

#5 Updated by john huxley over 3 years ago

  • Description updated (diff)

#6 Updated by Anders Svensson over 3 years ago

  • Classification changed from C - Minor to Public Item

#7 Updated by Richard Hilton almost 2 years ago

Hello
Please can you advise whether you have tried the v2.5.10.0 beta, and if it helped at all
(same update added to 16 reports so apologies if you have already mentioned this)

For instructions on how to access the beta please refer to the relevant section of this Beamblog update

Thanks

#8 Updated by Kristin Warren almost 2 years ago

  • Status changed from New to Needs More Info

#9 Updated by Kristin Warren almost 2 years ago

  • Status changed from Needs More Info to Closed - Not an Issue

Thank you for your bug report! Due to 30 or more days of inactivity, we are closing this ticket. If you are still encountering the issue, please file a new bug including updated information at https://support.baldursgate.com/

Also available in: Atom PDF