Bug #24658

[Linux] Game should not chmod 700 user home directory on save

Added by Bertrand Legendre almost 3 years ago. Updated almost 3 years ago.

Status:Closed - DupeStart date:06/28/2016
Classification:Public ItemDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Found In Version:Public Bug Reports - 2.3.67.3

Description

When the game is saved (quick or normal save) on BG:EE Linux (Steam version), user home directory is chmod to 700, preventing access to other users (i.e. Apache, shared folders with samba, etc).

Steps to reproduce
1. Give access (access/read) to group and others with "chmod 755 ~"
2. Check the previous command has worked with "ls -ld ~" : it will show as "drwxr-xr-x"
3. Run BG:EE, start ou load a game
4. Alt-tab out of the game and check with "ls -ld ~", it will still show as "drwxr-xr-x"
5. Alt+Tab to game, and save the game (quicksave or normal save)
6. Alt+Tab out of the game, and check again with "ls -ld ~"

Observed
Home directory is now 700 "drwx------"

Expected
Home directory should have been left untouched at 755 "drwxr-xr-x"

History

#1 Updated by Anders Svensson almost 3 years ago

  • Classification changed from C - Minor to Public Item

#2 Updated by Jamie Beadle almost 3 years ago

  • Status changed from New to Closed - Dupe

Duplicate of #22341.

Also available in: Atom PDF