Bug #23982

French and several other languages not working anymore in beta 2.3.67.1 of BGEE

Added by Denis Ribayrol over 3 years ago. Updated over 3 years ago.

Status:Closed - FixedStart date:06/04/2016
Classification:C - MinorDue date:
Assignee:-% Done:

100%

Category:-
Target version:Public Bug Reports - 2.3.67.2
Found In Version:

Description

  1. Launch any of the following builds:
    BG:EE Beamdog
    BG:EE Steam
    SoD Beamdog
    SoD Steam
    (BG:EE/SoD GOG
  2. Go to Options -> Language, select a language that uses both male and female TLKs:
    French
    German
    Italian
    Japanese
    Polish
    Portuguese
    Russian (only SoD Steam build affected)
    Spanish
    Ukranian (only SoD Steam build affected)
  3. Click Done, quit and restart the game
  4. Check the in-game text, e.g. the BG1 intro movie subtitles (not the UI)

Observed
The game is in English. The localized male dialog.tlk is missing from the respective build.

Expected
The game should be in the selected language. The localized male dialog.tlk should not be missing.

Notes

Internal report #23960

Additional info:

Found with BGEE beta 2.3.67.1, Beamdog standalone client
Further observation:
- dialog.tlk file is missing in lang/fr_FR, dialogF.tlk is still present
- same thing happens in de_DE, es_ES, it_IT, ja_JP, pl_PL, pt_BR, I guess these languages are not working anymore too

This can be fixed by asking to fix the installation, even after removing the 00764 directory.
This is new to 2.3.67.1. Version 2.3.67.0 didn't have this problem.
This has been reported by a Steam user too : https://forums.beamdog.com/discussion/comment/782399/#Comment_782399

History

#1 Updated by Denis Ribayrol over 3 years ago

Hardware and software configuration (may not be relevant to the issue):
Windows 7 64 bits
AMD Phenom II 9750, 8 GB RAM, ATI HD4850

#2 Updated by Filip Flechtner over 3 years ago

Note that the issue is known internally. We will process this ticket shortly.

#3 Updated by Keith Marshall over 3 years ago

  • Description updated (diff)
  • Status changed from New to Submitted

#4 Updated by Keith Marshall over 3 years ago

  • Description updated (diff)

#5 Updated by Keith Marshall over 3 years ago

  • Description updated (diff)

#6 Updated by Anders Svensson over 3 years ago

  • Target version set to Next Update

#7 Updated by Filip Flechtner over 3 years ago

  • Status changed from Submitted to Closed - Fixed
  • % Done changed from 0 to 100
  • Found In Version deleted (Next Update)

Fixed in v2.3.67.2.

#8 Updated by Jeff "Cerevant" Payne over 3 years ago

  • Target version changed from Next Update to 2.3.67.2

Also available in: Atom PDF