Bug #23866

[Windows] There should be no lag when picking up equipment in the inventory with larger parties

Added by Adam "Adul" Zsoldos over 3 years ago. Updated 11 months ago.

Status:Closed - FixedStart date:05/27/2016
Classification:Public ItemDue date:
Assignee:-% Done:

100%

Category:-
Target version:Public Bug Reports - Next Update
Found In Version:Public Bug Reports - 2.2.66.0

Description

1. Load the attached save
2. Press "I" to go to the inventory screen
3. Click Kondar +1 in order to pick it up

Observed behavior:
There is lag when picking up the item.

Expected behavior:
There is no lag when picking up the item.

Notes

Same issue as #20530, still present in version 2.2.66.0.

Could be caused by the portrait highlighting and equipment comparison scripts being fired.

My specs:

OS: Windows 7 Ultimate x64
CPU: AMD Phenom II X4 965 3.39 GHz
RAM: 8 GB
Video card: GeForce GTX 970 4GB

Internal report #23971

InventoryLagTest.zip - Save game (656 KB) Adam "Adul" Zsoldos, 05/27/2016 09:37 AM

InventoryLagTestVideo.mp4 (14.4 MB) Anders Svensson, 01/04/2018 12:56 AM

History

#1 Updated by Keith Marshall over 3 years ago

  • Description updated (diff)
  • Status changed from New to Submitted

#2 Updated by Keith Marshall over 3 years ago

Do you get this issue in BG2EE as well?

#3 Updated by Adam "Adul" Zsoldos over 3 years ago

Yes.

#4 Updated by Jeff "Cerevant" Payne over 3 years ago

  • Classification changed from C - Minor to Public Item

#5 Updated by Keith Marshall almost 2 years ago

  • File deleted (InventoryLagTestVideo.mp4)

#6 Updated by Keith Marshall almost 2 years ago

Woops. Sorry about that. I meant to download that and not delete it (a copy of it is in the internal report however).

#8 Updated by Anders Svensson 11 months ago

  • Status changed from Submitted to Closed - Fixed
  • Target version set to Next Update
  • % Done changed from 0 to 100

Fixed in version 2.6.0.0.

Also available in: Atom PDF