Bug #23456

Ferrusk should not turn hostile or have nothing to say when completing his quest

Added by Kampf Kaninchen about 3 years ago. Updated about 3 years ago.

Status:Closed - FixedStart date:05/08/2016
Classification:C - MinorDue date:
Assignee:-% Done:

100%

Category:-
Target version:Public Bug Reports - 2.2.66.0
Found In Version:Public Bug Reports - 2.1.63.2

Description

1. Load the attached Druids save.
2. Exit east and travel to the Underground River entrance.
3. C:ExploreArea()
4. Locate the oak tree at x500 y1300 and jump there (Ctrl/J).
5. Respond to the druids (1, 1, 3).
6. Force attack a druid to free him, then agree to help him (1, 1, 1).
7. Locate the Underground River entrance at x2600 y600) and jump there (Ctrl/J).
8. Walk through the entrance.
9. C:ExploreArea()
10. Locate Ferrusk at x3200 y3200 and jump there (Ctrl/J).
11. Respond to Ferrusk (1, 1).
12. Open the doors to the southeast and speak to Ferrusk to the east (1, 1, 1, 1, 2, 3, 1, 4).
13. Return to the oak tree and speak to Jamven (2, 1).
14. Kill Jamven and Ferrusk, then pick up their heads.
15. Return to the Underground River but travel to the poisoned crusaders at x1800 y3500.
16. Speak to the crusaders (1, 1, 1).
17. Jump to Ferrusk and speak to him (1, 2, 2, 2, 3).
18. Return to the Underground River Entrance but travel to the myconids at x4400 y3000.
19. Respond to the Myconid (1, 1, 1).
20. Open the container to the east, then respond to the Myconid Elder (1, 1).
21. Kill the myconids (Ctrl/y) and pick up the bloom sac.
22. Return to the Underground River and speak to Ferrusk (1).
23. Return to the crusader and speak to him (1, 1).
24. Kill the mustard jelly (Ctrl/Y).
25. Return to Ferrusk and speak to him.

Observed
Ferrusk has nothing to say (v2.2 beta) or attacks (V2.1).

Expected
Ferrusk should have a range of normal dialogue options.

Note
Internal report #23377.

Skipping steps 15-24 sees the quest complete as expected. The poisoned crusaders quest and the good druids quest both appear to be using global variable BD_SDD315.

Original report, with the xyz save:
Observed behaviour:
Freed the druids, accepted their quest, met with Ferrus first time, proceeded to his lair with the dropping point for the seeds. Talked to him again, accepted his quest to kill the druids, did so, returned with their heads. Talked to him, his line is "I told you to stay away. You should have listened!" And he turns hostile.

Expected behaviour:
Ferrus recognises the two heads I brought and does not turn hostile without reason.

Fixed it for me with changing Global("BD_SDD315","GLOBAL",5) to Global("BD_SDD315","GLOBAL",4)

Ferrus then gives his line as per state 7 and I can choose to reply with Response 16 and all is fine. Don't really know what sets this variable at value 5, afaik I have done nothing to anger him. Savefile attached.

000000131-xyz.zip (644 KB) Kampf Kaninchen, 05/08/2016 06:19 PM

000000329-Druids.zip (132 KB) Richard Hilton, 05/09/2016 02:52 PM

History

#1 Updated by Richard Hilton about 3 years ago

  • Description updated (diff)

Was going to refer it back as it worked for me with a clean save, but it looks like the poisoned crusaders quest is connected into it.

#2 Updated by Richard Hilton about 3 years ago

#3 Updated by Richard Hilton about 3 years ago

  • Subject changed from Ferrus does not recognise the trophy heads and turns hostile to Ferrusk should not turn hostile or have nothing to say when completing his quest
  • Description updated (diff)
  • Status changed from New to Submitted

#4 Updated by Kampf Kaninchen about 3 years ago

Indeed, I did the poisoned crusaders quest after I accepted to kill the druids, but before I actually did so. Sorry, forgot to mention it.

If you help the crusaders, then this will set the variable/value in question Global("BD_SDD315","GLOBAL",5)

See BDPCRUS.DLG State 17.

#5 Updated by Anders Svensson about 3 years ago

  • Target version set to Next Update

#6 Updated by Anders Svensson about 3 years ago

  • Description updated (diff)

#7 Updated by Anders Svensson about 3 years ago

  • Status changed from Submitted to Closed - Fixed
  • % Done changed from 0 to 100

#8 Updated by Jeff "Cerevant" Payne about 3 years ago

  • Target version changed from Next Update to 2.2.66.0

Also available in: Atom PDF