Bug #23088

Strings for "Shaman" et al. should not be messed up

Added by Richard Hilton over 3 years ago. Updated over 3 years ago.

Status:Closed - FixedStart date:04/12/2016
Classification:C - MinorDue date:
Assignee:-% Done:

100%

Category:-
Target version:Public Bug Reports - 2.2.66.0
Found In Version:

Description

  1. Launch the standalone BG:EE build (without SoD installed)
  2. Start a new BG:EE game
  3. C:StartStore("taerum")
  4. Right-click the flail
  5. Scroll down to see the usability list

Observed
Between Monk and Thief, you see "Never Show Again".

Expected
Between Monk and Thief, you should see "Shaman".

Notes
Internal report #22726

See screenshots. All strings at the bottom of ENGINEST.2da are misassigned. Likely because ENGINEST.2da in the BG:EE build contains two different spelling variants of GUI_LOWER_NEVER_SHOW_AGAIN:

STRTRF_GUI_LOWER_NEVER_SHOW_AGAIN                        24351
STRREF_GUI_LOWER_NEVER_SHOW_AGAIN                        24351 

 

wrong_strings0.jpg wrong_strings1.jpg

wrong_strings2.jpg wrong_strings3.jpg

wrong_strings0.jpg (192 KB) Filip Flechtner, 04/12/2016 06:22 PM

wrong_strings1.jpg (205 KB) Filip Flechtner, 04/12/2016 06:22 PM

wrong_strings2.jpg (178 KB) Filip Flechtner, 04/12/2016 06:22 PM

wrong_strings3.jpg (185 KB) Filip Flechtner, 04/12/2016 06:22 PM

History

#1 Updated by Richard Hilton over 3 years ago

  • Status changed from New to Submitted

#2 Updated by Filip Flechtner over 3 years ago

  • Status changed from Submitted to Closed - Fixed

This was already fixed and confirmed in v2.1.63.2.

#3 Updated by Jeff "Cerevant" Payne over 3 years ago

  • Target version changed from Next Update to 2.2.66.0

Also available in: Atom PDF