Bug #23038

The achievement Defender should not unlock after meeting Hephernaan

Added by S Jensen over 3 years ago. Updated over 3 years ago.

Status:Closed - FixedStart date:04/25/2016
Classification:C - MinorDue date:
Assignee:-% Done:

0%

Category:-
Target version:Public Bug Reports - 2.2.66.0
Found In Version:Public Bug Reports - 2.1.63.2

Description

  1. Load the attached save game.
  2. Move to [1063.902]
  3. Answer ( 1 ) in dilaogue with Hephernaan.
  4. Kill ( Ctrl-Y ) the hostiles.
  5. Hephernaan will flee.
  6. Check a global: C:GetGlobal("ACH_DEFENDER","GLOBAL")

Observed

The global is 1.

Expected

The global doesn't exist.

Notes

The description is "Successfully defended the coalition camp from attack."

Internal report #23127.

000000220-Heph.zip (182 KB) Anders Svensson, 04/26/2016 04:31 PM

History

#1 Updated by Anders Svensson over 3 years ago

  • Subject changed from Various Achievement Issues to The achievement Defender should not trigger too early
  • Description updated (diff)
  • Status changed from New to Submitted
  • Found In Version changed from 2.0.62.2 to 2.1.63.2

Original report:
I'd like to preface this by saying that obviously I am unable to recreate any of these glitches, see as achievements only ever unlock once. That said, I noticed many achievements in Siege of Dragonspear (as well as both BG and BGII, though I won't address those here) do not appear to function as intended. As of now, I am only missing 7 of the Dragonspear achievements. I wanted to report which had problems unlocking and give info on my experience. All of these were on Steam and in patch 2.0 unless otherwise stated.

Glitched Achievements:

Defender: Did not unlock for me upon defending the camp. I had backtracked a bit in the Underground River section in an attempt to avoid advancing the story, but managed to advance the story anyway. I poisoned the Crusade's supplies and obtained that achievement, but then reloaded it because I did not want the story progress. I did not discover Hephernaan in the castle. I did however place the barrel of bwoosh. Later I decided to load one of my previous saves to discover what I had missed, and when I found Hephernaan, both Hasty Retreat and Defender unlocked. My speculation is Defender may only unlock if Hephernaan was discovered before defending the camp.

Family Secrets: This one is a little unclear. For me it unlocked at the same time as Seeker of Secrets, which appears to be unlocking as expected. Seems like Family Secrets should have unlocked upon discovering the secret room back in the Korlasz family tomb.

String Cutter: I reported this already, and it seems as though it's being worked on, so I won't go in depth. Should unlock upon killing Darkshelin instead of Ziatar.

In the Name of the Father / Amendments: Both of these achievements unlocked simultaneously when I ordered Madele to amend her murderous ways. Only Amendments should have unlocked. I don't know if both would have unlocked if I had told her to go forth and murder in the name of Bhaal first.

Nature Lover / Dark Ally: There's definitely something wrong here, though it's hard to figure out what exactly. I got Dark Ally first, no problems, then on a reload I went for Nature Lover and the achievement didn't pop when I finished it. It did pop however when I reentered the Underground River area, instead of upon completing the quest. My brother played this part on the following patch (2.1.63.2) and he did them in reverse order. Nature Lover popped just fine, Dark Ally never popped for him.

Possibly Glitched (I'm unable to verify if I'm doing everything exactly as intended or not, but I speculate these are glitched too based off of descriptions I have found online):

You Chose... Poorly: The description I have found online is "Thrix claimed a party member's soul." I've intentionally messed up the riddle so he would claim someone's soul, and no achievement. I've tried with different characters, and have tried most, if not all of the dialogue lines. My brother was also unable to get this in 2.1.63.2.

Grim Deeds to Come...: "Fell to attackers outside Baldur's Gate." Sounds like this should unlock upon finishing the game, but it doesn't, and the Steam stats show 0% of players have obtained this.

Riddlemaster: "Answered the menhir's riddle, Vidhyadar's riddle, and Thrix's riddle correctly." I've done all three riddles across different save files, so unless they all have to be done on the same file, it's not working.

Side notes: I'm not sure what the requirements are for All of the Allies and All of the Enemies, so I can't speculate on them. It would be nice to get a description of what exactly is needed for them so I could test them.

#2 Updated by Anders Svensson over 3 years ago

  • File 000000220-Heph.zip added
  • Subject changed from The achievement Defender should not trigger too early to The achievement Defender should not unlock after meeting Hephernaan
  • Description updated (diff)

#3 Updated by Anders Svensson over 3 years ago

  • Description updated (diff)

#4 Updated by Anders Svensson over 3 years ago

Family Secrets: Reported as issue #23142.

#5 Updated by Anders Svensson over 3 years ago

String Cutter: Reported as issue #22283.

#6 Updated by Anders Svensson over 3 years ago

In the Name of the Father: Reported as issue #23143.

#7 Updated by Anders Svensson over 3 years ago

  • Target version set to Next Update

#8 Updated by Alan Watson "ajwz" over 3 years ago

  • Status changed from Submitted to Closed - Fixed

#9 Updated by Anders Svensson over 3 years ago

Nature Lover: Reported internally as issue #23266.

#10 Updated by Anders Svensson over 3 years ago

Dark Ally: No obvious problems when I test.

#11 Updated by Anders Svensson over 3 years ago

You Chose... Poorly: Reported internally as issue #23270.

#12 Updated by Anders Svensson over 3 years ago

Grim Deeds to Come...: Reported internally as issue #23273.

#13 Updated by Anders Svensson over 3 years ago

Riddlemaster: No obvious problems when I test. The riddles need to be answered in the same playthrough, yes.

#14 Updated by Anders Svensson over 3 years ago

All the Allies: You need to enlist the Ogres (Slug and Murs) and the Golem (The Vanished) so they are present at the Dragonspear Castle battle.
All the Enemies: Have Strunk, Munsch, Julann, and Rigah present at the Dragonspear Castle battle and kill them all.

#15 Updated by Jeff "Cerevant" Payne over 3 years ago

  • Target version changed from Next Update to 2.2.66.0

Also available in: Atom PDF