Bug #22947

Wands of Magic MIssile should not give the "Uneffected by the effects of the wand" message when used against a valid target

Added by Daniel Rehr over 3 years ago. Updated over 3 years ago.

Status:Closed - FixedStart date:04/21/2016
Classification:C - MinorDue date:
Assignee:-% Done:

0%

Category:-
Target version:Public Bug Reports - 2.2.66.0
Found In Version:Public Bug Reports - 2.1.63.2

Description

1) Load the attached save
2) Press F9 and click on the tutor to fire the magic missile at him

Observed

You get the message "Uneffected by the effects of the wand"

Expected

Wands of Magic Missile should not give the "Uneffected by the effects of the wand" message when used against a valid target

Notes

This looks to be a problem in BG2EE as well.

The issue is caused by effect opcode 324 (Immunity to spell and message) with param1=0 and param2=126 (Stat CON >= 0).

Reported internally as #23002

000008270-Wands.zip (134 KB) Keith Marshall, 04/23/2016 11:17 PM

History

#1 Updated by Keith Marshall over 3 years ago

  • File 000008270-Wands.zip added
  • Subject changed from Wand of Magic Missiles should hit any target as per item description to Wands of Magic MIssile should not give the "Uneffected by the effects of the wand" message when used against a valid target
  • Description updated (diff)
  • Status changed from New to Submitted

#2 Updated by Keith Marshall over 3 years ago

  • Description updated (diff)

#3 Updated by Anders Svensson over 3 years ago

  • Target version set to Next Update

#4 Updated by Scott David over 3 years ago

  • Status changed from Submitted to Closed - Fixed

#5 Updated by Jeff "Cerevant" Payne over 3 years ago

  • Target version changed from Next Update to 2.2.66.0

Also available in: Atom PDF