Bug #22836

[Multiplayer] Starting a new game should not crash when using a language other than English

Added by Szymon Rodzeń over 3 years ago. Updated about 3 years ago.

Status:Closed - FixedStart date:04/17/2016
Classification:C - MinorDue date:
Assignee:-% Done:

0%

Category:-
Target version:Public Bug Reports - 2.2.66.0
Found In Version:Public Bug Reports - 2.1.63.2

Description

1. Change the game language to Polish.
2. Quit the game and restart it.
3. Create a new multiplayer game with two Abdel pregens.
4. Assign the second Abdel to a client session.
5. Click Start.

Observed
The game screen is briefly shown then crashes for both client and host.

Expected
The game should not crash.

Note
Intrnal report #22852

Affects BGEE and BGIIEE

History

#1 Updated by Richard Hilton over 3 years ago

  • Status changed from New to Needs More Info

Hi
Can you start a multiplayer game with no clients?
& are host and all clients using the same version of the game such as v2.1.63.2.

Could you also advise whether host and clients are using the BGEE executable with blue user interface, or SoD executable with black user interface. If you are mixing part and part, does the problem remain if everyone uses one or the other?
Thanks

#2 Updated by Szymon Rodzeń over 3 years ago

I am able to start a multiplayer game with no clients.
All clients and host use last version from Steam and we're on BGEE executable with blue user interface. We don't have an opportuinty to test it with SoD since nobody in our party bought this DLC, but we've heard (from Beamdog forums) that our issue doesn't occur in SoD.

#3 Updated by Richard Hilton over 3 years ago

Understod
Could you advise how many clients are trying to connect and pc/mac/linux combinations.
At what point does it crash, in character arbitration, generating/importing characters or when you click start.
What happens if you try to add one client at a time.
& can you get everyone's crash dumps attached in zip format - they should each compress down to 500k or so, with a zip name so we can refer to each such as host, client1, client2 etc.

Thanks

#4 Updated by Richard Hilton over 3 years ago

OK, I can reproduce if I switch the game language to Polish - I take it you're not using English?

#5 Updated by Richard Hilton over 3 years ago

  • Subject changed from Game crashes in the beggining [multiplayer only] to [Multiplayer] Starting a new game should not crash when using a language other than English
  • Description updated (diff)

#6 Updated by Richard Hilton over 3 years ago

  • Status changed from Needs More Info to New

#7 Updated by Richard Hilton over 3 years ago

  • Description updated (diff)
  • Status changed from New to Submitted

#8 Updated by Szymon Rodzeń over 3 years ago

Richard Hilton wrote:

OK, I can reproduce if I switch the game language to Polish - I take it you're not using English?

Nope, I'm not. It's Polish, as you probably figured by yourself. :)
So if the bug is reproduceable I guess that it won't be necessary to point out how many clients connected and on which platforms. We'll test our game in English and if something new happens I will report it there immediately but I think you got everything right.

#9 Updated by Anders Svensson about 3 years ago

  • Target version set to Next Update
  • Found In Version changed from Next Update to 2.1.63.2

#11 Updated by Richard Hilton about 3 years ago

  • Status changed from Submitted to Closed - Fixed

#12 Updated by Jeff "Cerevant" Payne about 3 years ago

  • Target version changed from Next Update to 2.2.66.0

Also available in: Atom PDF