Bug #22814

Quick Saving in Previous Version MP Save Game Should Not Crash Game

Added by Kyle Foerster over 3 years ago. Updated almost 2 years ago.

Status:Closed - FixedStart date:04/16/2016
Classification:C - MinorDue date:
Assignee:-% Done:

0%

Category:-
Target version:Public Bug Reports - 2.2.66.0
Found In Version:Public Bug Reports - 2.1.63.2

Description

Description
After my friend and I started a Siege of Dragonspear multiplayer game when the game first released, we made it all the way to Chapter 10 (I believe) just before the Siege of Dragonspear castle. The problem was, that on that version of the game we could not progress because my client's game kept crashing in the middle of the siege battle. So we decided to wait until the next patch (2.1.63.2) to give a try again, as it stated Multiplayer was now far more stable.

However, we ran into several issues. Secondly, when we attempted to quick save after looting our surroundings on this older save game, the game crashed immediately for host.

Steps to Reproduce:
1 - Load the saved game provided in the zip file (SaveGame2.zip)
2 - Start multiplayer session (preferably with two people)
3 - Loot surroundings for a bit
4 - Have the host attempt to quick save
6 - Game crashes (if it doesn't crash, dmp was created due to crash on host's side)

Summary - I feel the details are self explanatory.

Expected Behavior - The game should not crash in this situation (it didn't before in the previous version).

Notes
Internal report #22843

SaveGame2.zip (617 KB) Kyle Foerster, 04/16/2016 03:19 PM

SaveGame2Dump.zip (583 KB) Kyle Foerster, 04/17/2016 04:13 PM

History

#1 Updated by Kyle Foerster over 3 years ago

Kyle Foerster wrote:

Description
After my friend and I started a Siege of Dragonspear multiplayer game when the game first released, we made it all the way to Chapter 10 (I believe) just before the Siege of Dragonspear castle. The problem was, that on that version of the game we could not progress because my client's game kept crashing in the middle of the siege battle. So we decided to wait until the next patch (2.1.63.2) to give a try again, as it stated Multiplayer was now far more stable.

However, we ran into several issues. Secondly, when we attempted to quick save after looting our surroundings on this older save game, the game crashed immediately for host.

Steps to Reproduce:
1 - Load the saved game provided in the zip file (SaveGame2.zip)
2 - Start multiplayer session (preferably with two people)
3 - Loot surroundings for a bit
4 - Have the host attempt to quick save
6 - Game crashes (if it doesn't crash, dmp was created due to crash on host's side)

Summary - I feel the details are self explanatory.

Expected Behavior - The game should not crash in this situation (it didn't before in the previous version).

Unfortunately my dmp files were not loading correctly due to "bad gateway"

#2 Updated by Richard Hilton over 3 years ago

  • Description updated (diff)
  • Status changed from New to Submitted

#3 Updated by Richard Hilton over 3 years ago

Please can you also check that host and all clients have the same game version.
Thanks

#4 Updated by Kyle Foerster over 3 years ago

Richard Hilton wrote:

Please can you also check that host and all clients have the same game version.
Thanks

Hi there,

Only one host and one client and we both have the same version. Thank you.

#5 Updated by Richard Hilton over 3 years ago

OK. Are you able to compress your most recent host and client crash dump into a zip format and attach that - the reduced size should help avoid the bad gateway message. The last from each of your documents -> infinity engine - enhanced edition.

#6 Updated by Kyle Foerster over 3 years ago

Attempting to attach it as SaveGame2Dump.zip as requested.

#7 Updated by Richard Hilton over 3 years ago

#8 Updated by Richard Hilton over 3 years ago

  • Target version set to Next Update

#9 Updated by Richard Hilton over 3 years ago

  • Status changed from Submitted to Closed - Fixed

#10 Updated by Jeff "Cerevant" Payne over 3 years ago

  • Target version changed from Next Update to 2.2.66.0

#11 Updated by Filip Flechtner almost 2 years ago

  • Found In Version changed from Next Update to 2.1.63.2

Also available in: Atom PDF