Bug #22813

[ToB Rassad] Picking up the Wheel of Obliteration too early should not break the end of Rasaad's quest

Added by Milan Aftanas over 3 years ago. Updated over 3 years ago.

Status:Closed - FixedStart date:04/16/2016
Classification:C - MinorDue date:
Assignee:-% Done:

0%

Category:-
Target version:Public Bug Reports - 2.2.66.0
Found In Version:Public Bug Reports - 2.1.63.2

Description

1. Load the attached ToB save.
2. Move east to Alorgoth, killing the shadows (Ctrl/Y).
3. Follow Alorgoth, killing any more shadows (Ctrl/Y).
4. Respond to Alorgoth (1), and wait for Yxtrazzal to turn into dragon form.
5. Pause the game (spacebar) and open the Quickloot bar (red button).
6. Kill Yxtrazzal while paused (Ctrl/Y) and loot her corpse without unpausing.
7. From the Inventory screen (I), equip the Wheel of Obliteration in a quickslot.
8. From the Game screen (G), unpause (spacebar).
9. Respond to Alorgoth (1).
10. Wait for Rasaad to say the portal should be opened.
11. Jump to the portal (Ctrl/j).
12. Use the Wheel of Obliteration (click it's quickslot).

Observed
The portal activates but nothing happens. Clicking again says you need to be near the gems.

Expected
Once the Wheel is activated, further dialogue and cutscene of the party leaving should take place.

Note
Internal report #23193

Can happen without pausing, if you grab the Wheel of Obliteration before Alorgoth reacts to the dragon death, but easier to repro while paused.

If you pick up the Wheel early, as per the Rasaad trapped screencap
  • Alorgoth modals "No! stay away from the wheel!"
  • Rasaad OT's open the portal
  • Using the Wheel near the portal opens it
  • Control returns to the player
  • Further attempts to use the Wheel see a you must be closer OT
If you wait to pick up the wheel, as per the Rasaad saved screencap
  • Rasaad modals your dragon is dead
  • You can then pick up the wheel
  • Alorgoth then OT's "No! Stay away from the Wheel!" instead of it being modal
  • Rasaad OT's open the portal
  • Using the Wheel near the portal opens it
  • Control returns to the player
  • Rasaad modals a you win dialogue
  • The cutscene continues and the party leave the area (abridged on the screencap unfortunately)

VIDEO:
https://drive.google.com/file/d/0B2zz7G_Djd3SWUVnZ0F2M09BMzQ/view?usp=sharing
(~100 MB)

FOUND IN VERSTION: 2.1.63.2
(this option is not in the list)

save_game_single.zip (986 KB) Milan Aftanas, 04/16/2016 03:06 PM

999001251-ToB Rasaad Speed of wheel.zip (1.05 MB) Richard Hilton, 04/28/2016 11:45 AM

2016-04-28-1709-15 Rasaad trapped.mp4 (3 MB) Richard Hilton, 04/28/2016 12:23 PM

2016-04-28-1710-53 Rasaad saved.mp4 (2.88 MB) Richard Hilton, 04/28/2016 12:24 PM

History

#1 Updated by Milan Aftanas over 3 years ago

  • Step 1: Check for Mods
    NO mods ever installed
    editor NOT used on that game
  • Step 2: Reproduce the issue.
    yes (10-times repeated), even tried to load older save (still same game)

I have played MULTI-PLAYER game and copy-pasted it to SINGLE-PLAYER in order to avoid game braking bug (reported in separate bug report), so this bug appears in SINGLE (the save was originaly multi-player)

STEPS:
1. Load the attached save.
2. Continue within quest (attack Alorgoth and Yxtrazzal)
3. Kill dragon Yxtrazzal
4. Imidiately pick-up Wheel of Obliteration

SHOULD:
Rassad dialog: "Your dragon is dead, Alorgoth! You will join her soon!" should trigger even if wheel of obliteration is picked up
SHOULD NOT:
picking Wheel of Obliteration before converzation triggers should not block the conversation and thus blocking any further progress in game (since this dialog does not trigger it is NOT possible to leave Shadowrealm = game over)

discussion about bug is here:
https://forums.beamdog.com/discussion/25473/rasaad-quest-wheel-of-obliteration

VIDEO:
https://drive.google.com/file/d/0B2zz7G_Djd3SWUVnZ0F2M09BMzQ/view?usp=sharing
(~100 MB)

FOUND IN VERSTION: 2.1.63.2
(this option is not in the list)

#2 Updated by Richard Hilton over 3 years ago

  • Status changed from New to Needs More Info

The dialogue triggers for me if I kill the dragon but don't pick up the wheel. Could you try that - and if it works the report needs to be amended to state picking the wheel up too early appears to be an issue.
Thanks

#3 Updated by Richard Hilton over 3 years ago

  • File 999001251-ToB Rasaad Speed of wheel.zip added
  • Subject changed from [Win10] {Steam} ToB Rassad Quest - Rassad dialog should trigger after killing Yxtrazzal to [ToB Rassad] Picking up the Wheel of Obliteration too early should not break the end of Rasaad's quest
  • Description updated (diff)
  • Status changed from Needs More Info to New

#5 Updated by Richard Hilton over 3 years ago

  • Description updated (diff)
  • Status changed from New to Submitted

#6 Updated by Anders Svensson over 3 years ago

  • Target version set to Next Update
  • Found In Version changed from Next Update to 2.1.63.2

#7 Updated by Scott David over 3 years ago

  • Status changed from Submitted to Closed - Fixed

#8 Updated by Jeff "Cerevant" Payne over 3 years ago

  • Target version changed from Next Update to 2.2.66.0

Also available in: Atom PDF