Bug #22812

Area Transitioning Multiplayer Saved Game After 2.1.63.2 Update Shouldn't Crash Game

Added by Kyle Foerster over 3 years ago. Updated almost 2 years ago.

Status:Closed - FixedStart date:04/16/2016
Classification:Public ItemDue date:
Assignee:-% Done:

0%

Category:-
Target version:Public Bug Reports - 2.2.66.0
Found In Version:Public Bug Reports - 2.1.63.2

Description

Description
After my friend and I started a Siege of Dragonspear multiplayer game when the game first released, we made it all the way to Chapter 10 (I believe) just before the Siege of Dragonspear castle. The problem was, that on that version of the game we could not progress because my client's game kept crashing in the middle of the siege battle. So we decided to wait until the next patch (2.1.63.2) to give a try again, as it stated Multiplayer was now far more stable.

However, we ran into several issues. Firstly, we immediately attempted to transition out of the coalition camp and the game crashed immediately.

Steps to Reproduce:
1 - Load the saved game provided in the zip file (SaveGame1.zip)
2 - Start multiplayer session (preferably with two people)
3 - Have Host attempt to leave the zone for Dragonspear Castle
4 - Game crashes (if it doesn't crash, dmp was created due to crash on host's side)

Summary - I feel the details are self explanatory.

Expected Behavior - The game should not crash in this situation (it didn't before in the previous version).

Note
Internal report #22191

SaveGame1.zip (594 KB) Kyle Foerster, 04/16/2016 03:14 PM

SaveGame1Dump.zip (553 KB) Kyle Foerster, 04/17/2016 04:14 PM

History

#1 Updated by Kyle Foerster over 3 years ago

Kyle Foerster wrote:

Description
After my friend and I started a Siege of Dragonspear multiplayer game when the game first released, we made it all the way to Chapter 10 (I believe) just before the Siege of Dragonspear castle. The problem was, that on that version of the game we could not progress because my client's game kept crashing in the middle of the siege battle. So we decided to wait until the next patch (2.1.63.2) to give a try again, as it stated Multiplayer was now far more stable.

However, we ran into several issues. Firstly, we immediately attempted to transition out of the coalition camp and the game crashed immediately.

Steps to Reproduce:
1 - Load the saved game provided in the zip file (SaveGame1.zip)
2 - Start multiplayer session (preferably with two people)
3 - Have Host attempt to leave the zone for Dragonspear Castle
4 - Game crashes (if it doesn't crash, dmp was created due to crash on host's side)

Summary - I feel the details are self explanatory.

Expected Behavior - The game should not crash in this situation (it didn't before in the previous version).

Unfortunately my dmp files were not loading correctly due to "bad gateway"

#2 Updated by Richard Hilton over 3 years ago

  • Description updated (diff)
  • Status changed from New to Submitted

#3 Updated by Kyle Foerster over 3 years ago

Attached Dump file as SaveGame1Dump.zip.

#4 Updated by Richard Hilton about 3 years ago

#5 Updated by Jeff "Cerevant" Payne about 3 years ago

  • Classification changed from C - Minor to Public Item

#6 Updated by Mark Ramsden almost 2 years ago

  • Status changed from Submitted to Closed - Fixed

This was fixed in 2.2.64.0.

#7 Updated by Filip Flechtner almost 2 years ago

  • Target version set to 2.2.66.0
  • Found In Version changed from Next Update to 2.1.63.2

Also available in: Atom PDF