Bug #22788

Double Tapping Arrow key then pressing a button should not make map scrolling get stuck in one direction

Added by Brad L over 3 years ago. Updated about 1 year ago.

Status:Closed - FixedStart date:04/15/2016
Classification:Public ItemDue date:
Assignee:-% Done:

100%

Category:-
Target version:Public Bug Reports - 2.5.17.0
Found In Version:Public Bug Reports - 2.0.62.2

Description

1. Start a new game with Abdel Pregen
2. Hover your mouse over the 'Reveal Details' button.
3. Double tab the up arrow [^], as your on the second tap press the 'Reveal Details' button.
4. Dont press anything and watch

Observed
The map keeps scrolling up uncontrollably

Expected
It should not be moving when your not pressing any keys.

Notes
Internal report #22845

-Im in window mode if that matters.
-Assumed same issue but not tested with BG2:EE and SoD.
-It also works when press any of the direction keys, left/down/right instead of up.
-It dosnt have to be the 'Reveal Details' button, it can be any button. Inventory, AI on, ect.
-Pressing Esc to bring up the menu the exiting the menu is the only way to fix it.

Personal note, This issue has been happening so much over all the patches, im so glad I finally figured it out >.<!

2016-04-17-1621-05.mp4 (894 KB) Richard Hilton, 04/17/2016 11:24 AM

History

#1 Updated by Brad L over 3 years ago

This is the second time I have tried to add a .gif showing the issue. Its only 16.8 mb out of the max 50mb but its not showing and saying 'Bad Gateway' for some reason.

#2 Updated by Richard Hilton over 3 years ago

  • File 2016-04-17-1621-05.mp4 added
  • Subject changed from [Windows 8.1 Steam] Double Tapping Arrow key then pressing a button shouldn't make map scrolling get stuck in one direction. to Double Tapping Arrow key then pressing a button should not make map scrolling get stuck in one direction
  • Description updated (diff)
  • Status changed from New to Submitted

#3 Updated by Jeff "Cerevant" Payne over 3 years ago

  • Classification changed from C - Minor to Public Item

#4 Updated by Brad L about 3 years ago

Im not sure if we are supposed to still reply here if we find an issue?

But this bug seems to have came back as im having the exact same behavior in BG1 atm while playing a new game starting in candle keep. Not tried with SoD or BG2.

#5 Updated by Faalagorn . about 2 years ago

I was able to recreate the issue on v. 2.3.67.3 of BG:EE with SoD installed, although I was clicking the "character record" button at that time. I think It might be related to Bug #31999 I reported earlier.

#6 Updated by Anders Svensson over 1 year ago

  • Status changed from Submitted to Closed - Fixed
  • Target version set to Next Update
  • % Done changed from 0 to 100

Fixed in version 2.5.13.0.

#7 Updated by Anders Svensson about 1 year ago

  • Target version changed from Next Update to 2.5.17.0

Also available in: Atom PDF