Bug #22244

Neera should retain her level, equipment and spells from the prologue

Added by Steve Bennet over 3 years ago. Updated about 1 year ago.

Status:Closed - FixedStart date:04/03/2016
Classification:Public ItemDue date:
Assignee:-% Done:

100%

Category:-
Target version:Public Bug Reports - 2.5.17.0
Found In Version:Public Bug Reports - 2.1.63.2

Description

  1. Load the attached save game "000000226-Troll_Claw_Neera."
  2. Travel to Boareskyr Bridge (you might get a random encounter on the way).
  3. Explore Map: C:ExploreArea()
  4. Jump ( Ctrl-J ) to [4396.1193]
  5. Use the nearby teleport circle.
  6. Answer ( 1 > 1 > 1 > 1 ) in dialogue with Khalid.
  7. Talk to Neera; select ( 1 > 1 > 1 )
  8. Open Neera's character record, inventory, and spell book.

Observed

Neera is level 7. She is only wearing a Knave's Robe and Adoy's Belt. Her spell book only has two level 5 spells.

Expected

Neera is level 9. She is wearing an Adventurer's Robe, Adoy's Belt, Relairs's Mistake, and other items. Her spell book has ten level 5 spells.

Notes

Neera is imported from the attached Final Save. If I play the game without reloading I get the expected result as can be seen in the save "000000229-Neera_OK."

Internal report #23297.

000000002-Final-Save.zip - BGEE save game used for SoD import (742 KB) Philipp Wiktorin, 04/21/2016 07:05 PM

000000226-Troll_Claw_Neera.zip (826 KB) Anders Svensson, 05/01/2016 09:44 AM

000000229-Neera_OK.zip (847 KB) Anders Svensson, 05/01/2016 09:44 AM

000000230-Neera_Not_OK.zip (847 KB) Anders Svensson, 05/01/2016 09:44 AM

History

#1 Updated by Jeff "Balquo" Smyth over 3 years ago

Could you attach the BGEE save you used when importing your party to SoD.

#2 Updated by Anders Svensson over 3 years ago

  • Status changed from New to Needs More Info

#3 Updated by Philipp Wiktorin over 3 years ago

I want to confirm that this bug seems to persist in 2.1.63.2. As far as I can tell, it affects Neera only. Even though she carries over everything in the prologue, levels, equipment, inventory and spells are lost in chapter 9.

I went ahead and attached the BGEE save I used to import my party to SoD.

#4 Updated by Anders Svensson over 3 years ago

  • Status changed from Needs More Info to New

#5 Updated by Anders Svensson over 3 years ago

Original report:
Neera doesn't appear to have her equipped gear from what she had at the end of the prologue.
I can't imagine this is intended being that every other returning party member encountered still retains their worn equipment.

#6 Updated by Anders Svensson over 3 years ago

  • Description updated (diff)

#7 Updated by Anders Svensson over 3 years ago

  • Description updated (diff)

#8 Updated by Jeff "Cerevant" Payne over 3 years ago

  • Classification changed from C - Minor to Public Item

#9 Updated by swit swit about 3 years ago

This report is related to this problem: https://forums.beamdog.com/discussion/comment/789128?
Same thing happens to Dorn. GAM entries duplication for these 2 NPCs is caused by bugs in DLG files. In order to fix it you should:
1. In DORN.DLG remove 3 instances of:
CreateCreatureObjectOffset("DORN",Myself,[0.0])
DestroySelf()

2. In NEERA.DLG remove 3 instances of:
CreateCreatureObjectOffset("NEERA",Myself,[0.0])
DestroySelf()

#10 Updated by Anders Svensson almost 2 years ago

  • Status changed from Submitted to Closed - Fixed
  • Target version set to Next Update
  • % Done changed from 0 to 100

Fixed for new games in version 2.5.2.0.

#11 Updated by Anders Svensson about 1 year ago

  • Target version changed from Next Update to 2.5.17.0

Also available in: Atom PDF