Bug #22201

[Windows] Mouse won't move screen down or right.

Added by Mitchell Sealy over 3 years ago. Updated about 1 year ago.

Status:Closed - FixedStart date:04/02/2016
Classification:Public ItemDue date:
Assignee:-% Done:

100%

Category:-
Target version:Public Bug Reports - 2.5.17.0
Found In Version:Public Bug Reports - 2.0.62.2

Description

1. Start with attached save.
2. Walk into the Friendly Arm In.
3. When Jopi approaches you, choose options 1, then 2.
4. Talk to Bentley Mirrorshade. Sell him a Fire Opal Ring and a Diamond.
5. Talk to Jaheira. Choose option 1.
6. Talk to Bentley Mirrorshade. Buy Jaheira a club and medium shield.
7. Equip Club and Medium Shield on Jaheira.
8. Alt Tab out of game, then back into game.
9. Pan the camera down and right with the mouse.

Observed
Game will not pan right or down.

Expected
Game should pan in all directions at all zoom levels.

Note
Internal report #21838

This will make the mouse stop moving the screen down or right when you move your mouse to either edge of the screen. If you save this problem persists in the save game after shutting down the game and reloading. Exiting and re-entering full screen mode does nothing.

BALDUR.SAV (28.3 KB) Mitchell Sealy, 04/02/2016 07:00 AM

BALDUR.gam - Gam file for that first save. (86.9 KB) Mitchell Sealy, 04/02/2016 10:16 AM

BALDUR.SAV - Save file where the issue is already in effect (31.2 KB) Mitchell Sealy, 04/02/2016 10:17 AM

BALDUR.gam - Gam file for the second save. (91.9 KB) Mitchell Sealy, 04/02/2016 10:18 AM

History

#1 Updated by Mitchell Sealy over 3 years ago

Additional note. Zooming in makes the screen move normally again.

Adding some other necessary files.

#2 Updated by Richard Hilton over 3 years ago

  • Description updated (diff)
  • Status changed from New to Submitted

#3 Updated by Richard Hilton over 3 years ago

  • Description updated (diff)

#4 Updated by Jeff "Cerevant" Payne over 3 years ago

  • Classification changed from C - Minor to Public Item

#5 Updated by Anders Svensson over 1 year ago

  • Status changed from Submitted to Closed - Fixed
  • Target version set to Next Update
  • % Done changed from 0 to 100

Fixed in version 2.5.15.1.

#6 Updated by Anders Svensson about 1 year ago

  • Target version changed from Next Update to 2.5.17.0

Also available in: Atom PDF