Bug #21720

Haer'Dalis's actor troupe should not be missing from the Planar Prison

Added by Adam "Adul" Zsoldos almost 3 years ago. Updated almost 3 years ago.

Status:Closed - Not an IssueStart date:03/22/2016
Classification:C - MinorDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Found In Version:Public Bug Reports - 2.0.60.0

Description

  1. Load attached save file

Observed: the actor troupe is missing, and the Planar Prison quest is unsolvable.

Expected: the actor troupe should be present, and they should initiate dialog with the player's party, finishing up the quest.

TroupeMissingBug.zip (352 KB) Adam "Adul" Zsoldos, 03/22/2016 05:21 AM

Portraits.zip - custom portraits (1020 KB) Adam "Adul" Zsoldos, 03/29/2016 03:50 AM

History

#1 Updated by Jamie Beadle almost 3 years ago

  • Status changed from New to Needs More Info

Do you have a save game from prior to entering the planer portal in the playhouse?

#2 Updated by Adam "Adul" Zsoldos almost 3 years ago

  • Status changed from Needs More Info to New

No, sorry. I didn't think to make a hard save, and by the time I had encountered the bug, I no longer had my autosave.

#3 Updated by Adam "Adul" Zsoldos almost 3 years ago

(But as I remember, the actors didn't remain in the playhouse. At least not by the portal, where I would have seen them.)

#4 Updated by Jamie Beadle almost 3 years ago

  • Status changed from New to Needs More Info

I've tried a couple times and I cannot reproduce the issue starting with a fresh game each time. Do you remember what you did during the playhouse quest?

#5 Updated by Adam "Adul" Zsoldos almost 3 years ago

  • Status changed from Needs More Info to New

I started the quest by going into Mekrath's lair in the Temple sewers (didn't visit playhouse beforehand). I got his mirror-fetching quest from him and finished it, and afterwards told him I had no use for a slave, told him the reward wasn't adequate, and killed him.

When talking to Haer'Dalis in Mekrath's lair I think I chose 1, 1 (sent him away). Then I got the planar gem and delivered it to the playhouse in the Bridge District.

At the playhouse I think something unusual happened, because normally Haer'Dalis initiates dialog first as you approach the troupe, but this time he did not initiate his dialog. So I spoke to Raelis instead (she initiated the dialog when I got close to her), and I gave her the gem.

I agreed to protect the troupe during the summoning, and did so. When the bounty hunters attacked I selected the first answer. When the bounty hunters and the actor troupe disappeared (all of them), I went into the portal.

In the Planar Prison I went the long route: I killed the Master of Thralls and destroyed the orb, and then killed the Warden. I also cleared out all the areas you can access through the fleshy traps. I slept a lot down there, so probably 5+ days have passed.

#6 Updated by Richard Hilton almost 3 years ago

Are you sure Haer'Dalis didn't join the party and start the reform party process?
& did you go into the portal immediately, or head elsewhere first.

I can see two oddities with the save so far.
  • The shadow fiend is still in the Playhouse, but can't be seen.
  • Raelis is in AR0500 (Bridge District) at x0 y0 in the save, but can't be seen.

#7 Updated by Anders Svensson almost 3 years ago

  • Status changed from New to Needs More Info

#8 Updated by Adam "Adul" Zsoldos almost 3 years ago

  • Status changed from Needs More Info to New

I'm certain Haer'Dalis did not join the party at any point throughout that game (not even momentarily).

I went into the portal immediately, right after the dialog when the bounty hunters and the actor troupe disappeared from the playhouse.

#9 Updated by Richard Hilton almost 3 years ago

Doing the following 3 commands sees Raelis arrive in the Planar Prison. This should be done in cutscene CUT17c which is where the bounty hunters and Raelis should leave the basement.

C:MoveToArea("AR0500")
C:Eval('ActionOverride("Raelis",MoveBetweenAreas("AR0516",[394.516],S))')
C:MoveToArea("AR0516)

Still thinking about how to recreate this - suspect the cutscene was interrupted in some way.

#10 Updated by Richard Hilton almost 3 years ago

Clutching at straws, could you attach the custom portraits for characters 2-5 please.

& were you playing in single player, or under multiplayer.
Thanks

#11 Updated by Adam "Adul" Zsoldos almost 3 years ago

Of course, here they are.

The game was single player, and I started it through the new custom party feature (characters imported from a Black Pits 1 save).

It might just be that this bug has a very low chance of occurring, or that the specific circumstances leading up to it are incredibly obscure. It might not be worth chasing this one.

#12 Updated by Richard Hilton almost 3 years ago

  • Status changed from New to Closed - Not an Issue

Setting to not an issue unless/until we can get further reports.
Thanks

Also available in: Atom PDF