Bug #21718

Difficulty setting should be remembered for individual save files.

Added by Christopher "Tresset" Ethier almost 3 years ago. Updated almost 3 years ago.

Status:Closed - DupeStart date:03/22/2016
Classification:C - MinorDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Found In Version:Public Bug Reports - 2.0.60.0

Description

  1. Start a new game with normal difficulty.
  2. Save this new game under the name "Normal Difficulty"
  3. Return to the main menu.
  4. Start another new game with Legacy of Bhaal difficulty.
  5. Load the "Normal Difficulty" game that was saved earlier.
  6. Press the "O" key and select "Gameplay".

Observed: Legacy of Bhaal mode is active in the game that was started at normal difficulty (you can tell because there is no difficulty slider present on this menu).

Expected: When this game is loaded the difficulty should still be on normal as it was when the game was saved.

Notes: A loaded game will always use whatever difficulty was last set, regardless of what the setting was when that particular game was saved. Were it not for issue #20540 I suspect the only way to turn off Legacy of Bhaal mode for all games would be to start a new game with a different setting.

History

#1 Updated by Jamie Beadle almost 3 years ago

  • Status changed from New to Closed - Dupe

Marked as duplicate. The issue is the same as the one from #20540. The problem was that it was being read from the user settings. It should no longer be read from the user profile settings, but from the save game.

Also available in: Atom PDF