Feature #21710

NPCs should be included in new games begun with 2 PCs

Added by Tilly Underwood over 3 years ago. Updated about 1 year ago.

Status:Closed - FixedStart date:03/21/2016
Classification:Public ItemDue date:
Assignee:-% Done:

100%

Category:-
Target version:Public Bug Reports - 2.5.17.0
Found In Version:Public Bug Reports - 2.0.60.0

Description

  1. Start SoD and select Single Player > New Game > Create Party.
  2. Click Create on the first slot and then import Meryll.
  3. Click Create on the second slot and then import Jagan Battleforge.
  4. Click Play and then Venture Forth.

Observed

When 2 PCs are made and a new game has begun, there are 0 NPCs in the party including Safana (thief).

Expected

When 2 PCs are made and a new game has begun, there are 4 NPCs in the party including Safana (thief).

Notes

Going through the first dungeon without a full party will be difficult for normal-skilled players. Going through the first dungeon without a thief (if a player didn't create a PC thief) is also difficult. To play a multiplayer game, we had to restart with extra characters to fill out the party.

Internal report: #31486

History

#1 Updated by Jeff "Cerevant" Payne over 3 years ago

  • Tracker changed from Bug to Feature

This is currently working as intended, but you make a valid point. We'll have another look post-ship.

#2 Updated by - Jalily - over 3 years ago

  • Subject changed from No NPCs are included in new games begun with 2 PCs to NPCs should be included in new games begun with 2 PCs

#3 Updated by Jeff "Cerevant" Payne over 3 years ago

  • Classification changed from C - Minor to Public Item

#4 Updated by Anders Svensson over 2 years ago

  • Description updated (diff)

#5 Updated by Anders Svensson over 2 years ago

  • Description updated (diff)
  • Status changed from New to Submitted

#6 Updated by Anders Svensson over 1 year ago

  • Status changed from Submitted to Closed - Fixed
  • Target version set to Next Update
  • % Done changed from 0 to 100

Fixed in version 2.5.11.0.

#7 Updated by Anders Svensson about 1 year ago

  • Target version changed from Next Update to 2.5.17.0

Also available in: Atom PDF