Bug #20964

[Windows, Beamdog] You should be able to turn off the Help tips by clicking the Help tab again

Added by Julius Borisov over 3 years ago. Updated about 3 years ago.

Status:Closed - DupeStart date:03/11/2016
Classification:C - MinorDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Found In Version:Public Bug Reports - 2.0.59.1

Description

1. Launch BG2EE and start a new game
2. After the initial dialogue, click the Help tab (the one with the question mark)
3. Try to click the Help tab again

Observed

The Help menu doesn't go when you click the Help tab again, so you have to click "Inventory" to take it off.

Expected

The Help menu goes away after you click the Help tab again, just as it was the case in the previous versions.

Notes
Tested on Windows XP.

yt-2016-mar-12-004.jpg (226 KB) Julius Borisov, 03/12/2016 05:22 AM

yt-2016-mar-12-005.jpg (226 KB) Julius Borisov, 03/12/2016 05:22 AM

yt-2016-mar-12-006.jpg (224 KB) Julius Borisov, 03/12/2016 05:22 AM

yt-2016-mar-12-007.jpg (223 KB) Julius Borisov, 03/12/2016 05:22 AM

yt-2016-mar-12-008.jpg (223 KB) Julius Borisov, 03/12/2016 05:22 AM

yt-2016-mar-12-009.jpg (224 KB) Julius Borisov, 03/12/2016 05:22 AM

yt-2016-mar-12-010.jpg (226 KB) Julius Borisov, 03/12/2016 05:22 AM

yt-2016-mar-12-011.jpg (226 KB) Julius Borisov, 03/12/2016 05:22 AM

yt-2016-mar-12-012.jpg (225 KB) Julius Borisov, 03/12/2016 05:22 AM

000000017-Shaman ToB.rar (118 KB) Julius Borisov, 03/15/2016 01:57 PM

Baldur.zip (1.5 KB) Julius Borisov, 03/23/2016 02:57 PM

History

#1 Updated by Richard Hilton over 3 years ago

Unable to reproduce this issue

#2 Updated by Julius Borisov over 3 years ago

Strange that you haven't been able to reproduce it. This is what I see when click the Help tab after the first time (the screenshots are attached). Maybe the clock can serve as a clue that the screenshots are made one-by-one in each second, i.e. I click and click and click, but the Help menu doesn't go away.

#3 Updated by Julius Borisov over 3 years ago

Ok, at least on my PC I've managed to create a save loading which in 100% cases lets you see this bug. It's a save from ToB.
I load it and click the Help tab. After that I can't take the Help menu off. The same happens if I click the Quick Loot bar symbol - after that it won't go away. Try it, please.

#4 Updated by Anders Svensson over 3 years ago

I can't reproduce it with the save game I'm afraid (but I'm on Windows 8.1).

#5 Updated by Jamie Beadle over 3 years ago

  • Status changed from New to Needs More Info

Unable to reproduce in 2.0.60.0 on Windows XP. I have also attempted to deliberately use non-Latin characters in the engine.lua file, still no luck -- tooltips seem to work fine.

Can you also attach your Baldur.LUA file?

#6 Updated by Julius Borisov over 3 years ago

That bug involves using non-Latin characters not only in the engine.lua file but also in the path to the my documents BG folder, like C:\Documents and Settings\Ana\Мои документы\Baldur's Gate II - Enhanced Edition

I'm sure it's connected to that bug.

I've tried once again the attached save - downloaded it and ran. The bug I'm describing here repeated.

This is my baldur.lua file.

#7 Updated by Anders Svensson over 3 years ago

  • Status changed from Needs More Info to New

#8 Updated by Julius Borisov about 3 years ago

In the beta version of 2.0.63.0 #20954 is fixed (I've checked it in the game). That fix also solved this problem. Thanks a lot!

#9 Updated by Richard Hilton about 3 years ago

  • Status changed from New to Closed - Dupe

Closing as a dupe of #20954 as that was the cause.
Thanks

Also available in: Atom PDF