Bug #20921

The mouse should move the camera down when zoomed fully out

Added by Mathew Suta almost 4 years ago. Updated over 1 year ago.

Status:Closed - FixedStart date:03/10/2016
Classification:Public ItemDue date:
Assignee:-% Done:

100%

Category:-
Target version:Public Bug Reports - 2.5.17.0
Found In Version:Public Bug Reports - 2.0.59.1

Description

1. Launch the game.
2. Switch to Fullscreen mode if in Windowed mode (Alt/Enter).
3. Start a new game with the Abdel pregen.
4. Confirm the mouse can scroll the camera down and right.
5. Switch out of the game (Alt/Tab).
6. Return to the game (click on the Taskbar icon).
7. Zoom out as far as the game allows (scroll wheel down).
8. Use the mouse to scroll right and then down.

Observed:
The camera can't be moved down.

Expected
The mouse should move the camera down when zoomed fully out.

Note:
Internal report #21225
Public report indicates scrolling right can also be affected, but not able to reproduce.
The extended zoom is mentioned in internal ticket #20867

Screenshot 2016-03-10 19.09.53.png - The cursor to the right of the chatbox is as far down as it will go, no scrolling. (2.34 MB) Mathew Suta, 03/10/2016 07:11 PM

History

#1 Updated by Anders Svensson almost 4 years ago

Please update your reports to use the correct format: https://forums.beamdog.com/discussion/46858/how-to-report-bugs

#2 Updated by Richard Hilton almost 4 years ago

  • Subject changed from Cannot scroll down or right when zoomed out to The mouse should move the camera down when zoomed fully out
  • Description updated (diff)

#3 Updated by Richard Hilton almost 4 years ago

  • Description updated (diff)
  • Status changed from New to Submitted

#4 Updated by Jeff "Cerevant" Payne over 3 years ago

  • Classification changed from C - Minor to Public Item

#5 Updated by Anonymous over 2 years ago

  • Description updated (diff)

#6 Updated by Anders Svensson almost 2 years ago

  • Status changed from Submitted to Closed - Fixed
  • Target version set to Next Update
  • % Done changed from 0 to 100

Fixed in version 2.5.15.1.

#7 Updated by Anders Svensson over 1 year ago

  • Target version changed from Next Update to 2.5.17.0

Also available in: Atom PDF